Turn on debugging from commandline (get those 6 more lines)

I am starting elasticsearch in a docker container and getting an error on startup. The entire error message is being hidden with the phrase ... 6 more (indicating there are 6 more lines of error messages). I have run docker-compose in verbose mode and tailing the logs and I still get this truncation, so it leads me to believe that it is elasticsearch that is truncating the debug message. I already tried this commandline option:

-E rootLogger.level=debug

But it did not work (still said ... 6 more).

How do I get elasticsearch to output all debug information using a commandline option?

(I am running elasticsearch version 5.1.2)

Would you please share the stack trace that you have?

The truncation that you're seeing is not from Elasticsearch, but rather the default handling of printing stack traces in Java. From the docs:

Note the presence of lines containing the characters "...". These lines indicate that the remainder of the stack trace for this exception matches the indicated number of frames from the bottom of the stack trace of the exception that was caused by this exception (the "enclosing" exception). This shorthand can greatly reduce the length of the output in the common case where a wrapped exception is thrown from same method as the "causative exception" is caught. The above example was produced by running the program:

edit: the problem was solved by updating my docker image to elasticsearch 5.3.3 (from 5.1.2). My docker binary must have updated to a newer version that was incompatible with the older elasticsearch image (I'm on arch linux, so bleeding edge). Thanks again for your extra eyes on this!

When I remove the root.Logger flag above I get this error message:


Here's the error I'm getting (when I try to use the root logger flag):


Thank you!

The correct setting to set the root log level is logger._root=debug or logger.level=debug (they do the same thing). Startup fails if you try to set an unrecognized setting. The issue that you're seeing when you do not set this setting is related to v2 cgroups and is fixed in v5.3.1 (https://github.com/elastic/elasticsearch/pull/23493).

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.