Type ignored when using a sort by _timestamp


(kevins) #1

My index has two types: story, tags

type story has the _timestamp enabled and stored

When I query this I get 50 hits of type STORY: (which is correct)

http://localhost:9200/index/story/_search?q=abc&size=50

When I query this I get 50 hits of type STORY and TAGS (which seems
incorrect)

http://localhost:9200/index/story/_search?q=abc&size=50&sort:_timestamp:desc

In other words, it seems to ignore the type in the URL. What could cause
this? My tags type does not use _timestamp.

Thank you.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

Interesting. Do you mind creating a full curl recreation? I would like to replay that.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

7 novembre 2013 at 23:11:20, Kevin S (kevinsteger@gmail.com) a écrit:

My index has two types: story, tags

type story has the _timestamp enabled and stored

When I query this I get 50 hits of type STORY: (which is correct)

http://localhost:9200/index/story/_search?q=abc&size=50

When I query this I get 50 hits of type STORY and TAGS (which seems incorrect)

http://localhost:9200/index/story/_search?q=abc&size=50&sort:_timestamp:desc

In other words, it seems to ignore the type in the URL. What could cause this? My tags type does not use _timestamp.

Thank you.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3