Unable to access into <ipaddress:9200> after installation of elastic search

Installed version: Elasticsearch-8.2.0
OS: RedHat 8.2 on Azure

Hello all
I am a new starter to use Elasticsearch and linux. Just tried to install the Elasticsearch 8.2. After I configured the yml file, allow the firewall to port 9200 & 9300 and start the Elasticsearch service, I still struggle to get into ipaddress:9200 from my browser.

May I please ask what should be done incorrectly in this situation? Thanks a lot.

Kind regards,
fanfan01127

Hi,

could you share the elastic config yml file.

Hi, Please see my config.yml file. Many thanks. :slight_smile:

------------------------------------ Node ------------------------------------

Use a descriptive name for the node:

#node.name: node-1

Add custom attributes to the node:

#node.attr.rack: r1

----------------------------------- Paths ------------------------------------

Path to directory where to store the data (separate multiple locations by comma):

path.data: /var/lib/Elasticsearch

Path to log files:

path.logs: /var/log/Elasticsearch

----------------------------------- Memory -----------------------------------

Lock the memory on startup:

#bootstrap.memory_lock: true

Make sure that the heap size is set to about half the memory available

on the system and that the owner of the process is allowed to use this

limit.

Elasticsearch performs poorly when the system is swapping the memory.

---------------------------------- Network -----------------------------------

By default Elasticsearch is only accessible on localhost. Set a different

address here to expose this node on the network:

network.host: 10.0.3.132

By default Elasticsearch listens for HTTP traffic on the first free port it

finds starting at 9200. Set a specific HTTP port here:

http.port: 9200

For more information, consult the network module documentation.

--------------------------------- Discovery ----------------------------------

Pass an initial list of hosts to perform discovery when this node is started:

The default list of hosts is ["127.0.0.1", "[::1]"]

discovery.seed_hosts: 10.0.3.132

Bootstrap the cluster using an initial set of master-eligible nodes:

#cluster.initial_master_nodes: ["node-1", "node-2"]

For more information, consult the discovery and cluster formation module documentation.

--------------------------------- Readiness ----------------------------------

Enable an unauthenticated TCP readiness endpoint on localhost

#readiness.port: 9399

---------------------------------- Various -----------------------------------

Allow wildcard deletion of indices:

#action.destructive_requires_name: false

#----------------------- BEGIN SECURITY AUTO CONFIGURATION -----------------------

The following settings, TLS certificates, and keys have been automatically

generated to configure Elasticsearch security features on 05-05-2022 09:08:05

--------------------------------------------------------------------------------

Enable security features

xpack.security.enabled: true

xpack.security.enrollment.enabled: true

Enable encryption for HTTP API client connections, such as Kibana, Logstash, and Agents

xpack.security.http.ssl:
enabled: true
keystore.path: certs/http.p12

Enable encryption and mutual authentication between cluster nodes

xpack.security.transport.ssl:
enabled: true
verification_mode: certificate
keystore.path: certs/transport.p12
truststore.path: certs/transport.p12

Create a new cluster with the current node only

Additional nodes can still join the cluster later

cluster.initial_master_nodes: ["Elasticsearch-test"]

Allow HTTP API connections from anywhere

Connections are encrypted and require user authentication

http.host: 0.0.0.0

Allow other nodes to join the cluster from anywhere

Connections are encrypted and mutually authenticated

#transport.host: 0.0.0.0

#----------------------- END SECURITY AUTO CONFIGURATION -------------------------

Hi,

it would be great if you put the content of the config file using </> so we can read the content.

please try this on the terminal and check if it working ,

curl -k -XGET https://IPaddress:9200

Hi - yes, I could see a popup to let me input the username and password. But when I try to input the default username (elastic) and password (changeme), I still couldn't get it in. So how can I get in there please?

After this, I also see below screenshot if I cancel to input the credential. Thank you.

Hi,

good, to change the elastic password run this command;

/usr/share/elasticsearch/bin/elasticsearch-reset-password -u elastic

Welcome to our community @fanfan01127! :smiley:

Please format your code/logs/config using the </> button, or markdown style back ticks. It helps to make things easy to read which helps us help you. Please don't also post pictures of text, logs or code. They are difficult to read, impossible to search and replicate (if it's code), and some people may not be even able to see them :slight_smile:

Thank you - all sorted for this part. :slight_smile: