Unable to activate keep_alive


(Benoît) #1

Hello,

I've added

network.tcp.keep_alive: true 

to elasticsearch.yml to activate keep alive.

After resart, nothing change :

$ curl -I http://localhost:9200
HTTP/1.1 200 OK
Content-Type: text/plain; charset=UTF-8
Content-Length: 0

Any idea ? How to check if an option from elasticsearch.yml is took into
account ?

Thanks, regards.

Benoît


(Shay Banon) #2

This control the TCP level socket keep alive setting, not HTTP. In terms of
HTTP, elasticsearch supports keep alive setting, and won't close the socket
if using HTTP 1.1 (and no CLOSE in the header), or when using HTTP 1.0 with
keep alive header (according to the spec).

On Tue, Jun 26, 2012 at 2:31 PM, Benoît benoit.intrw@gmail.com wrote:

Hello,

I've added

network.tcp.keep_alive: true

to elasticsearch.yml to activate keep alive.

After resart, nothing change :

$ curl -I http://localhost:9200
HTTP/1.1 200 OK
Content-Type: text/plain; charset=UTF-8
Content-Length: 0

Any idea ? How to check if an option from elasticsearch.yml is took into
account ?

Thanks, regards.

Benoît


(system) #3