Unable to delete a failed job in Machine Learning Beta

machine-learning

(Niket Vyas) #1

Hi,

I want to delete a failed job.

A pop-up appears and an error is displayed.

36 pm

The stopping and deleting datafeed fails because the datafeed was already deleted when I tried to delete it the job the first time.

I recently started using Kibana and can't figure out how to delete it even after reading through topics in the forum. Please help me solve this.


(rich collier) #2

What happens if you manually try to stop the Datafeed (https://www.elastic.co/guide/en/x-pack/5.4/ml-stop-datafeed.html)

POST _xpack/ml/datafeeds/<feed_id>/_stop

and/or try to manually delete the Datafeed (https://www.elastic.co/guide/en/x-pack/5.4/ml-delete-datafeed.html)

DELETE _xpack/ml/datafeeds/<feed_id>

What are the replies to the above API calls? Is there other interesting info in the elasticsearch.log when trying to invoke the above?

If neither of these are successful, perhaps restarting elasticsearch may help?


(Niket Vyas) #3

Hi Rich,

The datafeed was stopped and deleted successfully when I tried to delete the job. Only the jobs won't delete.

Thanks.


(rich collier) #4

Ok, thanks for the clarification. If executing a force delete on the job (https://www.elastic.co/guide/en/elasticsearch/reference/5.5/ml-delete-job.html)

DELETE _xpack/ml/anomaly_detectors/<job_id>force=true

If that doesn't fix things then see if there are any hung ML processes. Usins ps on the box, grep for the autodetect process - this is the C++ process that runs the ML code. If there are still remnant processes, still running, then kill them and then delete the job.


(Niket Vyas) #5

I updated Kibana to 5.5.2 and it solved the issue.
Thanks Rich! :smiley:


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.