Unable to deploy functionbeat to s3 bucket

Hello Team,
I was experimenting with /functionbeat-7.0.0-beta1-linux-x86_64.
When I try to deploy I always get the error,
2019-03-07T18:20:44.997Z DEBUG [aws.executor] aws/executor.go:46 The executor is executing '6' operations for converging state
2019-03-07T18:20:44.997Z DEBUG [aws] aws/op_ensure_bucket.go:31 Verifying presence of S3 bucket: umcloudwatch
2019-03-07T18:20:44.997Z DEBUG [aws.executor] aws/executor.go:68 The executor is rolling back previous execution, '0' operations to rollback
2019-03-07T18:20:44.997Z DEBUG [aws.executor] aws/executor.go:81 The rollback is successful
2019-03-07T18:20:44.997Z DEBUG [aws] aws/cli_manager.go:269 Deploy finish for function 'cloudwatch'
Function: cloudwatch, could not deploy, error: bucket 'umcloudwatch' already exist and you don't have permission to access it
2019-03-07T18:20:44.997Z DEBUG [cli-handler] cmd/cli_handler.go:64 Deploy execution ended
Fail to deploy 1 function(s)

Tried with all permissions and in the end gave public access to the bucket.

If I give a nonexistent bucket name also, the same error with that bucket name is displayed even though there is no bucket.

This is my very simple configuration ,

functionbeat.provider.aws.deploy_bucket: "umcloudwatch"

functionbeat.provider.aws.functions:

  • name: cloudwatch
    enabled: true
    type: cloudwatch_logs
    triggers:
    • log_group_name: /aws/lambda/myHelloWorld
      output.elasticsearch:
      hosts: ["localhost:9200"]

Thanks ,
Bhavani

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.