Unable to download kibana dashboard


(Stewart Bapor) #1

Hi
im having issues in setting up winlogbeats, i cant seem to get past the point ( currently following official logstash tutorial) of installing the kibana dash board

whenever i run this command:

scripts\import_dashboards.exe

i get the following error:

PS C:\Program files\winlogbeat> scripts\import_dashboards.exe
Failed to set the mapping: Put http://127.0.0.1:9200/.kibana/_mapping/search: dial tcp 127.0.0.1:9200: connectex: No con
nection could be made because the target machine actively refused it.
Created temporary directory C:\Users\RS1\AppData\Local\Temp\tmp760503195
Downloading https://artifacts.elastic.co/downloads/beats/beats-dashboards/beats-dashboards-5.4.3.zip
Unzip archive C:\Users\RS1\AppData\Local\Temp\tmp760503195
Importing Kibana from C:\Users\RS1\AppData\Local\Temp\tmp760503195\beats-dashboards-5.4.3\filebeat
Importing Kibana from C:\Users\RS1\AppData\Local\Temp\tmp760503195\beats-dashboards-5.4.3\heartbeat
Importing Kibana from C:\Users\RS1\AppData\Local\Temp\tmp760503195\beats-dashboards-5.4.3\metricbeat
Importing Kibana from C:\Users\RS1\AppData\Local\Temp\tmp760503195\beats-dashboards-5.4.3\packetbeat
Importing Kibana from C:\Users\RS1\AppData\Local\Temp\tmp760503195\beats-dashboards-5.4.3\winlogbeat
Import directory C:\Users\RS1\AppData\Local\Temp\tmp760503195\beats-dashboards-5.4.3\winlogbeat/index-pattern
Import index to /.kibana/index-pattern/winlogbeat-* from C:\Users\RS1\AppData\Local\Temp\tmp760503195\beats-dashboards-5
.4.3\winlogbeat\index-pattern\winlogbeat.json

Error importing URL/file: Failed to import index-pattern: Failed to load directory C:\Users\RS1\AppData\Local\Temp\tmp76
0503195\beats-dashboards-5.4.3\winlogbeat/index-pattern:
error loading C:\Users\RS1\AppData\Local\Temp\tmp760503195\beats-dashboards-5.4.3\winlogbeat\index-pattern\winlogbeat.
json: couldn't load json. Error: Put http://127.0.0.1:9200/.kibana/index-pattern/winlogbeat-*: dial tcp 127.0.0.1:9200:
connectex: No connection could be made because the target machine actively refused it.
Exiting


(Magnus Bäck) #2

As this is more of a Winlogbeat question I suspect you'll get better help in the Beats group.


(Stewart Bapor) #3

how do i put this forward in the beats group ?


(Magnus Bäck) #4

Edit your post and change its category.


(Steffen Siering) #5

Error message: No connection could be made because the target machine actively refused it.

Is Elasticsearch running, using port 9200 and reachable?


(Stewart Bapor) #6

At the time yes, elasticsearch was running on my Ubuntu machine perfectly fine, along with logstash and kibana. Had to do a fresh install recently so im going to reconfigure everything and then get back to you and see if i have the same issues.


(Stewart Bapor) #7

I've got everything up and running and i can confirm that elasticsearch is running using port 9200 and is reachable (Used curl to check)

By the way i am new to ubuntu and logstash so clear steps would be appreciated.


(Steffen Siering) #8

Doing curl http://<esip>:9200/.kibana from the machine filebeat is running on works?
You still get the same error?

Thing is, the TCP connect (that has been refused) is basically created by the OS. There shouldn't be a difference between curl and beats here.


(Stewart Bapor) #9

its winlogbeats im trying to make work. The Elk stack is installed on Ubuntu and i have whereas ive got winlogbeats on a windows 7 machine. Is there more information you need from me ? i can get it if it helps.


(Steffen Siering) #10

So, from which machine did you run curl? Can you check Elasticsearch is reachable from your windows machine? Depending on the configuration in elasticsearch, it might only bind to the host machine (that is, it's only accessible from the ubuntu server).


(system) #11

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.