Unable to execute metric beat command & unable to view on kibana


(Kranthi ) #1

Hi All,
Two problems I am facing currently with the metric beat
I have installed metricbeat on pc successfully but now I am unable to enable the modules. Its showing as apache not exist.
Current my working directory is /usr/share/metricbeat/modules.d
[root@Sibin modules.d]# metricbeat modules enable mysql
Module mysql doesn't exist!

Log file of metricbeat after starting the service

2018-09-05T14:15:18.327+0530 INFO instance/beat.go:273 Setup Beat: metricbeat; Version: 6.4.0
2018-09-05T14:15:18.327+0530 INFO pipeline/module.go:98 Beat name: Earth
2018-09-05T14:15:18.327+0530 INFO instance/beat.go:367 metricbeat start running.
2018-09-05T14:15:18.327+0530 INFO [monitoring] log/log.go:114 Starting metrics logging every 30s
2018-09-05T14:15:18.327+0530 INFO cfgfile/reload.go:140 Config reloader started
2018-09-05T14:15:48.329+0530 INFO [monitoring] log/log.go:141 Non-zero metrics in the last 30s {"monitoring": {"metrics": {"beat":{"cpu":{"system":{"ticks":10,"time":{"ms":19}},"total":{"ticks":30,"time":{"ms":48},"value":30},"user":{"ticks":20,"time":{"ms":29}}},"info":{"ephemeral_id":"d5de602f-f24c-4069-837d-f04b7659f330","uptime":{"ms":30027}},"memstats":{"gc_next":4194304,"memory_alloc":2821696,"memory_total":6956464,"rss":19427328}},"libbeat":{"config":{"module":{"running":0},"reloads":2},"output":{"type":"logstash"},"pipeline":{"clients":0,"events":{"active":0}}},"system":{"cpu":{"cores":4},"load":{"1":0,"15":0,"5":0.01,"norm":{"1":0,"15":0,"5":0.0025}}}}}}

Please resolve this


(Kranthi ) #2

###################### Metricbeat Configuration Example #######################

This file is an example configuration file highlighting only the most common

options. The metricbeat.reference.yml file from the same directory contains all the

supported options with more comments. You can use it as a reference.

You can find the full configuration reference here:

https://www.elastic.co/guide/en/beats/metricbeat/index.html

#========================== Modules configuration ============================

metricbeat.config.modules:

Glob pattern for configuration loading

path: ${path.config}/modules.d/*.yml

Set to true to enable config reloading

reload.enabled: true

Period on which files under path should be checked for changes

#reload.period: 10s

#==================== Elasticsearch template setting ==========================

setup.template.settings:
index.number_of_shards: 1
index.codec: best_compression
#_source.enabled: false

#================================ General =====================================

The name of the shipper that publishes the network data. It can be used to group

all the transactions sent by a single shipper in the web interface.

#name:

The tags of the shipper are included in their own field with each

transaction published.

#tags: ["service-X", "web-tier"]

Optional fields that you can specify to add additional information to the

output.

#fields:

env: staging

By the way Output I has enabled as Logstash


(Kranthi ) #3

Now on kibana its showing like this:

As of now I have enabled the output as Elasticsearch. Please help me to sort it out this issue.


(Carlos PĂ©rez Aradros) #4

Hi,

6.4 has a known bug with modules directory, more details can be found here: https://github.com/elastic/beats/issues/8104

6.4.1 will fix the issue and modules will be back on it's folder

Br


(Kranthi ) #5

Error creating runner from config: 1 error: 1 error: metricset 'http/status' is not registered, metricset not found

Now I am getting this error,could you please resolve this ? I am unable to get this issue.

What are the metricset need to enable for http, I have alreay go through the metricset modules page but i didn't get what to write in the http.yml!!


(Kranthi ) #6

Is anybody there to resolve this issue!


(Andrew Kroh) #7

What module are you trying to enable? The http module does not contain a status metricset. It has a json and server metricset as described here.

Heartbeat has a http monitor that can check the server status. Perhaps that's what you want?


(Kranthi ) #8

Thanks for the reply,
Yes I am expecting the sever status it working fine.
Now like I need to monitor http like APM services do is there any alternatives for that one!


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.