Unable to filter percolators when stemming is used on the index


(Brett Anderson) #1

I've found a strange bug when I try and use the percolator filter
functionality. I.e. I create a bunch of percolators then include a query
when I percolate a document so that it is only percolated against
percolators that match the query. This functionality usually works really
well, but I get strange results when I set the default analyzer to use
stemming. I've created a bug report in the GitHub repo herehttps://github.com/elasticsearch/elasticsearch/issues/1935.
Am I doing something wrong or is this a bug? I haven't tried explicitly
setting up the percolators with specific analyzer settings and leaving the
default analyzer standard, which could potentially solve this problem.
However it is more convenient to modify the default analyzer in this way
and the filtering issue does seem like a bug.

Thanks,
LJ.


(Shay Banon) #2

Looks like a bug, see the comment on the issue.

On Fri, May 11, 2012 at 3:56 AM, Laser Jesus
brett.anderson.ftw@gmail.comwrote:

I've found a strange bug when I try and use the percolator filter
functionality. I.e. I create a bunch of percolators then include a query
when I percolate a document so that it is only percolated against
percolators that match the query. This functionality usually works really
well, but I get strange results when I set the default analyzer to use
stemming. I've created a bug report in the GitHub repo herehttps://github.com/elasticsearch/elasticsearch/issues/1935.
Am I doing something wrong or is this a bug? I haven't tried explicitly
setting up the percolators with specific analyzer settings and leaving the
default analyzer standard, which could potentially solve this problem.
However it is more convenient to modify the default analyzer in this way
and the filtering issue does seem like a bug.

Thanks,
LJ.


(system) #3