Unable to get metrics for single process in metricbeat 6.2.2


I am unable to get metrics for single process (custom c# console application) in metricbeat 6.2.2. I have configured metricbeat.yml properly,Can anyone tell me whats going wrong in below configuration.

path: ${path.config}/modules.d/*.yml
reload.enabled: true

  • module: system
    • cpu
    • filesystem
    • memory
    • network
    • process
      enabled: true
      period: 10s
      processes: ['consolesssms.exe']

Thanks in advance !!!

Please attach your full configuration. Also, format it using </>.
What is the failure? Do you see any error messages in your logs? Could you attach your full debug logs (./metricbeat -e -d "*")?

Below is the full configuration,Let me know whats going wrong.. It would be very helpful if you can provide me sample for system >> Process >> processes module

? "-module"
: system
metricbeat.modules: ~
- process
path: "${path.config}/modules.d/*.yml"
- [^consolessms.exe$]
reload.enabled: true
- [""]
setup.dashboards.enabled: true
setup.dashboards.url: ~
host: ""
index.codec: best_compression
index.number_of_shards: 1
xpack.monitoring.elasticsearch: ~
xpack.monitoring.enabled: false />

Could you provide debug logs also?

hello kvch,

 I am trying to know the format/syntax to get metrics of a single process.. Not sure why you are asking logs etc

I have followed steps during installation and added [^consolessms.exe$] to get metrics of only consolessms.exe process, but its not working fine and loading all the metrics into elasticsearch.

Let me know if [^consolessms.exe$] syntax is correct. If not Please provide me the format of process -> processes tag to get metrics of single process in a machine.


Your regex seems fine. Could you please format your configuration properly using </> so I can validate that there isn't any whitespace error?
I am asking for the debug logs, because it might tell us what is going wrong in Metricbeat.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.