Unable to Join New node to existing cluster


I'm using Elasticsearch 8.4 version.
I was able to install Elasticsearch and Kibana.
Then I tried to install on 2nd node.

I followed the steps in https://www.elastic.co/guide/en/elasticsearch/reference/current/rpm.html

But, after I installed Elasticsearch on 2nd node, it always creates as new cluster.

How can I avoid this issue..?

Thank You...!

Please share your configuration and logs from one of these new nodes.

1 Like

If it's brand new :stuck_out_tongue: node you can create config with pointing other nodes and than use this tool:

cd /usr/share/elasticsearch/bin

and than:

sudo ./elasticsearch-node detach-cluster

But please be very careful - you're doing it at your own risk :slight_smile:

1 Like

It's not really enough to hint that there might be some risks here when the advice you've given is potentially very dangerous, leading to possible data loss, and is not at all correct either. There is never any need to detach-cluster on a brand-new node - the reference manual describes the proper steps perform in that case. Even if this were good advice, I still recommend you also link to the docs for the elasticsearch-node tool which describe the risks in extensive detail.

1 Like

When I was setting up my first cluster using Ansible I set it just like in manual with docs open at second screen. I tried for three days. There always was different cluster ids on each node (got three of them). Why? Probably tasks were completed in similar or even same time. That was the one and only way to add new node.

1 Like

It'd be better to start a new topic on this avenue of discussion please, let's keep to the OPs problem.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.