Unable to overwrite module input

Hi,

I am trying to disable a module input and specify my own.
As seen in https://github.com/elastic/beats/blob/master/x-pack/filebeat/module/checkpoint/firewall/config/firewall.yml , if we specify 'false' for input.var it should render an input object. So I want to specify my own with the following.

Code:

filebeat.modules:

- module: checkpoint

  firewall:

    var.input: "false"

    input:

      pipeline: checkpoint

      protocol:

        tcp:

          host: "0.0.0.0:8001"

          ssl:

            enabled: true

            certificate_authorities: ["certs/ca.crt"]

            certificate: "certs/filebeat.crt"

            key: "certs/filebeat.key"

            verification_mode: "full"

            client_authentication: "required"

 

output.elasticsearch:

  hosts: ["[http://localhost:9200](http://localhost:9200/)"]

# index: "filebeat-%{[agent.version]}-%{+yyyy.MM.dd}"

  pipeline: "checkpoint"

  protocol: "http"

~

However this always returns: No paths were defined for input accessing config, as if the module still uses the log module. Ideas?