Unable to register a repo with repository-s3 plugin

I am getting an error while trying to register a repo with type s3. I am using Elasticsearch 6.6.0
i have created the secure string as per below

Error response is:
{"error":{"root_cause":[{"type":"repository_verification_exception","reason":"[reponame] path is not accessible on master node"}],"type":"repository_verification_exception","reason":"[reponame] path is not accessible on master node","caused_by":{"type":"i_o_exception","reason":"Unable to upload object [tests-RPhRUR78TFy98osj5GAn9A/master.dat] using a single upload","caused_by":{"type":"sdk_client_exception","reason":"The requested metadata is not found at"}}},"status":500}

i am stuck with this quite for sometime
i have tried using allow_insecure_settings: true this breaks Elasticsearch service with and error
unknown setting [allow_insecure_settings]
please check that any required plugins are installed, or check the breaking changes doc
umentation for removed settings

issue was with the environment script available in the bin once i have marked it to the valid conf dir. It worked for me.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.