Unable to RUN bulk API client from different server -- NoNodeAvailableException


(TIru) #1

I am doing a POC using Elastic Search, when I ran a Bulkload Client on Same server where Elastic Search is running it is working fine, where I moved the BlukLoad client to another batch server I started getting this error. (to confirm network connectivity I verified from another server by executing curl, curl it is working fine )
To resolve this error I had to downgrade Elastic Search to 1.7.5.
I am using java version "1.8.0_71"
Elastic Search 2.2.0 (Where I got the error ) I also tried (2.1.2 same error ).

NoNodeAvailableException[None of the configured nodes are available: [{#transport#-1}{xxx.xx.xx.xx}{hostName/xxx.xx.xx.xx:9300}]]
at org.elasticsearch.client.transport.TransportClientNodesService.ensureNodesAreAvailable(TransportClientNodesService.java:290)
at org.elasticsearch.client.transport.TransportClientNodesService.execute(TransportClientNodesService.java:207)
at org.elasticsearch.client.transport.support.TransportProxyClient.execute(TransportProxyClient.java:55)
at org.elasticsearch.client.transport.TransportClient.doExecute(TransportClient.java:286)
at org.elasticsearch.client.support.AbstractClient.execute(AbstractClient.java:351)
at org.elasticsearch.action.ActionRequestBuilder.execute(ActionRequestBuilder.java:85)
at org.elasticsearch.action.ActionRequestBuilder.execute(ActionRequestBuilder.java:59)
at com.citi.code.es.TCBulkRequester.loadFromFile(TCBulkRequester.java:115)
at com.citi.code.es.BulkLoader.main(BulkLoader.java:30)


(Mark Walkom) #2

Did you tell ES to listen on a non-loopback address?

See Connectivity issues with a new/upgraded 2.X cluster? Read here first :)


(TIru) #3

Yes I did configured non-loopback address by mentioning below in config
network.host: xxx.xx.xxx.xx

To be specific, this is happening only for bluk API, using JAVA API search is working fine.


(system) #4