Unable to Set UP TLS for Kibana

Hi,

I've encountered a problem when trying to disable TLSv1.1 for Kibana using the command below:

server.ssl.supportedProtocols: "TLSv1.2"

However, after adding that command, the Kibana cannot be started:

Jan 19 03:39:51 systemd[1]: kibana.service: Main process exited, code=exited, status=1/FAILURE
Jan 19 03:39:51 systemd[1]: kibana.service: Failed with result 'exit-code'.
Jan 19 03:39:54 systemd[1]: kibana.service: Service RestartSec=3s expired, scheduling restart.
Jan 19 03:39:54 systemd[1]: kibana.service: Scheduled restart job, restart counter is at 3.
Jan 19 03:39:54 systemd[1]: Stopped Kibana.
Jan 19 03:39:54 systemd[1]: kibana.service: Start request repeated too quickly.
Jan 19 03:39:54 systemd[1]: kibana.service: Failed with result 'exit-code'.
Jan 19 03:39:54 systemd[1]: Failed to start Kibana.

After disabling the command, the Kibana can be started. Below the snapshot of kibana.yml:

# Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.
# These settings enable SSL for outgoing requests from the Kibana server to the browser.
server.ssl.enabled: true
server.ssl.certificate: /etc/kibana/certs/data01.crt
server.ssl.key: /etc/kibana/certs/data01.key
#server.ssl.supportedProtocols: "TLSv1.2"

Are there any config that I'm missing?

From what you've described, it seems like you're on the right track but might be facing an issue with the SSL configuration for Kibana. The error you're seeing after setting server.ssl.supportedProtocols: "TLSv1.2" suggests that Kibana is having trouble with this specific setting.

Have you tried with server.ssl.supportedProtocols: ["TLSv1.2"]? Per the documentation this setting is an array.