Unable to start elasticsearch on Ubuntu 18

I have installed Elasticsearch 7 on Ubuntu VERSION="18.04.2 LTS (Bionic Beaver)" and I am unable to start the service after attempting a million options I always get the same error :
root@PiEKStack:/var/log/elasticsearch# service elasticsearch status
ā— elasticsearch.service - Elasticsearch
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sat 2019-04-13 17:57:50 CEST; 31s ago
Docs: http://www.elastic.co
Process: 2195 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=78)
Main PID: 2195 (code=exited, status=78)

I believe it could be a GC issue from the logs but still unable to resolve it so far.Service starts and switches off after a few seconds

Anyone had the same issue?

Might be better if you post the logs instead of just your theory...

I have solved this.. Issue was with bootstrap checks:
https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.