Unable to start kibana.service

I have installed Kibana and elastic search in Linux (RHEL). I am able to run both kibana and elastic search manually. I want to start the service. Unfortunately, I am unable to find kibana.service file anywhere. I have tried to create kibana.service file and start it. But, I am not able to do.

Below it the error msg I get

● kibana.service - Kibana
Loaded: loaded (/etc/systemd/system/kibana.service; disabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Tue 2019-11-12 11:17:32 CET; 6min ago
Docs: https://www.elastic.co/guide
Process: 12822 ExecStart=/opt/ELK_Stack/Kibana/kibana-6.8.0/bin/kibana -c /etc/kibana/kibana.yml (code=exited, status=1/FAILURE)
Main PID: 12822 (code=exited, status=1/FAILURE)

Nov 12 11:17:30 ****************** systemd[1]: Started Kibana.
Nov 12 11:17:32 ****************** systemd[1]: kibana.service: main process exited, code=exited, status=1/FAILURE
Nov 12 11:17:32 ****************** systemd[1]: Unit kibana.service entered failed state.
Nov 12 11:17:32 ****************** systemd[1]: kibana.service failed.

Kibana.service

Kibana systemd service

[Unit]
Description=Kibana
Documentation=https://www.elastic.co/guide
After=network.target

[Service]
Type=simple
EnvironmentFile= /etc/default/kibana
User=kibana
Group=kibana
ExecStart= /opt/ELK_Stack/Kibana/kibana-6.8.0/bin/kibana "-c /etc/kibana/kibana.yml"

[Install]
WantedBy=multi-user.target

Kindly help me in this.

The service file should be created directly by the RPM distro of Kibana. https://www.elastic.co/guide/en/kibana/current/rpm.html
Did you use that or did you use the tar.gz distros?

Earlier I have used tar.gz. Later on I have uninstalled everything tried installing using RPM. Now service file is created automatically.

Now I have another issue. I have got SSL certificates. I want to configure it. Could you please guide how to do it. Kibana is installed in Linux RHEL 7.

Thanks in advance

You can follow these guides for that:
https://www.elastic.co/guide/en/kibana/current/configuring-tls.html

The blog post is the more detailed one.

Thanks for the help Marius. I have got SSL certificate using Servers Host name. Can I use the same certificate for both Elasticsearch and Kibana?

if they are both hosted on the same server, yes.

Hi Marius. Thank you for helping me out. I could add SSL certificate to Kibana and it is working. I am trying the same for elasticsearch. The guide says about enabling xpack sevurity. But, I could not see xpack settings in elasticsearch.yml file. Kindly suggest me in this regard.

I have installed elasticsearch 6.8.4 in Linux RHEL using RPM.