Unable to update analyzer


(kanchan) #1

Hi,
I have used tokenizer as below:
"text_general_likely_new": {
"tokenizer": "standard ",
"filter": [
"StopFilterFactory",
"LowerCaseFilterFactory",
"SynonymFilterFactory",
"ASCIIFoldingFilterFactory"
]
}

But I think there was a space like "standard " while defining tokenizer.So it is showing error like:

{
"error": {
"root_cause": [
{
"type": "exception",
"reason": "Failed to verify index [historical_new/QGeFAxAUS7qHd4NlgeC_5g]"
}
],
"type": "exception",
"reason": "Failed to verify index [historical_new/QGeFAxAUS7qHd4NlgeC_5g]",
"caused_by": {
"type": "illegal_argument_exception",
"reason": "Custom Analyzer [text_general_likely] failed to find tokenizer under name [standard ]"
}
},
"status": 500
}

Now I changed it without space like: "tokenizer": "standard" but still showing same error changes doesn't it.

Please let me know solution for it.


(Jimferenczi) #2

Which version of es are you using ? There was a bug at some point that made any invalid updates to the setting of a closed index non recoverable. This was fixed in 5.4.1:


If you are on 5.x you should upgrade to the latest version: 5.5.2 which has the fix for this issue.


(kanchan) #3

Thanks..... I am using elasticsearch 5.3.0


(Jimferenczi) #4

Then you are affected by this bug and should upgrade to 5.5 which has a fix.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.