Unassigned missng shards after node failure

Hi how's going every body. the proble is one of the shards of an specific index on a cluster is unassigned. the problem occures when a cluster node left, after rejoining to the cluster the shard reamain unassigned so we tried to reroute

POST /_cluster/reroute?retry_failed&master_timeout=1h

but this was unsuccessful. we also checked the data directory to find the shard in its index ID directory but again couldnt find it.
note that, we don't have any replicas of that shard and also snapshots of that index.
shard information:

{
  "index" : "index_name",
  "shard" : 4,
  "primary" : true,
  "current_state" : "unassigned",
  "unassigned_info" : {
    "reason" : "NODE_LEFT",
    "at" : "2022-12-31T13:22:12.533Z",
    "details" : "node_left [o8z5o9qcTCC6EFBEP7ewrg]",
    "last_allocation_status" : "no_valid_shard_copy"
  },
  "can_allocate" : "no_valid_shard_copy",
  "allocate_explanation" : "cannot allocate because a previous copy of the primary shard existed but can no longer be found on the nodes in the cluster"
}

we also tried to make assign it again to make things ok with:

POST _cluster/reroute?metric=none
{
  "commands" : [
  {"allocate_stale_primary" : {
  "index" : "index_name", "shard" : 4,
  "node" : "node2",
  "accept_data_loss" : true
    }
  }
  ]
}

but we got

No data for shard [4] of index [index_name] found on any node