Unassigned shards during upgrade


(alexandre) #1

Hi all,

I peformed an upgrade from ES 5.0.1 to 5.5. Each time I reloaded a node it tooks a long time (hours) to realocate unassigned shards !

I tried to avoid it with the commands below:

PUT _cluster/settings
{
  "transient": {
    "cluster.routing.allocation.enable": "none"
  }
}

and

PUT _all/_settings
{
  "settings": {
    "index.unassigned.node_left.delayed_timeout": "5m"
  }
}

But it didn't change anything. It still tooks a long time.

There is any possibility to avoid the unassigned shards and perform an upgrade in a faster way ?

Thanks in advance,
Alex


(Boaz Leskes) #2

I suspect shard had to be resynced which may cause large file copies. Have you read and followed the procedure described in https://www.elastic.co/guide/en/elasticsearch/reference/current/rolling-upgrades.html ?


(alexandre) #3

Hi,

Thanks for your answer. Yes I did it.


(Boaz Leskes) #4

OK. Did you validate that the synced flush was successful and did you make sure indexing was stopped? (it invalidates the synced flush)


(alexandre) #5

Hello,

I tried this also, but it doesn't change anything.
In my comprehension, the point here is the option bellow:

PUT _cluster/settings
{
  "transient": {
    "cluster.routing.allocation.enable": "none"
  }
}

and

PUT _all/_settings
{
  "settings": {
    "index.unassigned.node_left.delayed_timeout": "5m"
  }
}

But I don't get why it doesn't work for me, and I get a lot of unassigned shards.


(Boaz Leskes) #6

I get a lot of unassigned shards.

Can you clarify what you mean exactly? I understood some shards are assigned and take a long time to initialize.

You mention two commands, but I presume you did more than just those two. Can you post a complete description of the procedure you followed?


(alexandre) #7

I followed the procedure describe here:

https://www.elastic.co/guide/en/elasticsearch/reference/current/rolling-upgrades.html


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.