Unknow Plugin Error When Install Plugin

Elasticsearch version ( bin/elasticsearch --version ):7.6.1

Plugins installed : none

JVM version ( java -version ):1.8.0_242

OS version ( uname -a if on a Unix-like system): Debian 9

I tried installing ik using elasticsearch-plugin. I used the command / usr / share / elasticsearch / bin / elasticsearch-plugin install. / Elasticsearch-analysis-ik-7.6.1.zip but got the result ERROR: Unknown plugin ./elasticsearch-analysis-ik-7.6.1 .zip . I had to try to decompress and install the plugin, and the plugin worked normally. I don't know what went wrong, I hope you guys have a look.

Could you format your post in a way we can see exactly what you typed?

But here's the documentation https://www.elastic.co/guide/en/elasticsearch/plugins/current/plugin-management-custom-url.html. You are missing the file:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.