Unknown repository type s3 when creating snapshot in 2.x


(Andrew Snow) #1

Hi,

I am trying to create an S3 repository using the exact same method (on the exact same server) that works fine on 1.7.

Request:

curl -XPUT "http://127.0.0.1:9200/_snapshot/s3autosnapshots" -d '{ "type": "s3", "settings": { "bucket": "xxx", "base_path": "production", "region": "us-west-2" } }'

Response:

{"error":{"root_cause":[{"type":"repository_exception","reason":"[s3autosnapshots] failed to create repository"}],"type":"repository_exception","reason":"[s3autosnapshots] failed to create repository","caused_by":{"type":"illegal_argument_exception","reason":"Unknown [repository] type [s3]"}},"status":500}

Same error in 2.0.1 and 2.1. I have installed the cloud-aws plugin in each case.


(David Pilato) #2

Can you share the output of:

GET _cat/plugins?v

And also your elasticsearch.yml (anonymized)?


(Andrew Snow) #3

Thanks for your help,

The plugin cat showed up completely blank - even though I was already using the kopf plugin.

I started from scratch with a blank elasticsearch.yml and suddenly it (S3 repository) began working properly, and the plugin list was there too.

There must be some incompatible options from the config I had been using in 1.7, which I'll need to go through now.


(David Pilato) #4

May be you did not restart your node?
But for sure plugins for 1.7 are incompatibles with 2.0 and you absolutely need to update them as well.


(Andrew Snow) #5

Definitely restarted - I saw the correction version displayed in the kopf node list.

Also definitely removed and reinstalled the plugins (new versions)


(Mukut Biharee) #7

I also got this error, initially I installed aws-cloud plugin only on one node and restated then I got this error.
After that installed aws-cloud on all nodes then restated all plugins then it worked.


(system) #8