Unknown setting ‘ssl_certificate_verification’ for elasticsearch error

Hello,

I am getting below error

Unknown setting 'ssl_certificate_verification' for elasticsearch
May 28 18:35:12 logstashdv logstash: [2019-05-28T18:35:12,308][ERROR][logstash.agent ] Failed to execute action {:action=>LogStash::PipelineAction::Create/pipeline_id:capPlan, :exception=>"LogStash::ConfigurationError", :message=>"Something is wrong with your configuration.", :backtrace=>["/usr/share/logstash/logstash-core/lib/logstash/config/mixin.rb:86:in config_init'", "/usr/share/logstash/logstash-core/lib/logstash/filters/base.rb:126:in initialize'", "org/logstash/plugins/PluginFactoryExt.java:78:in filter_delegator'", "org/logstash/plugins/PluginFactoryExt.java:248:in plugin'", "org/logstash/plugins/PluginFactoryExt.java:184:in plugin'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:71:in plugin'", "(eval):117:in initialize'", "org/jruby/RubyKernel.java:1047:in eval'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:49:in initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:90:in initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline_action/create.rb:43:in block in execute'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:96:in block in exclusive'", "org/jruby/ext/thread/Mutex.java:165:in synchronize'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:96:in exclusive'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline_action/create.rb:39:in execute'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:334:in block in converge_state'"]}

following are filter elasticsearch plugin of my configuration

elasticsearch {
hosts => ["https://e1:9200", "https://e2:9200", "https://e3:9200"]
user => "username"
password => "aaaaa"
ssl => true
ssl_certificate_verification => true
ca_file => "/etc/logstash/elastcertsipdns/ca/"
query_template => "/usr/share/logstash/templates/capPlan.json"
index => "caplan"
fields => {
"totalSizeInBytes" => "[staleSizeInBytes]"
}
}

the elasticsearch filter is not the same as the output.

there is no ssl_certificate_verification.
https://www.elastic.co/guide/en/logstash/current/plugins-filters-elasticsearch.html#plugins-filters-elasticsearch-options

And there is a Bug for the ssl option.
I cant find the link now. but you dont need to user

ssl => true

just use the

elasticsearch {
hosts => ["https://e1:9200", "https://e2:9200", "https://e3:9200"]
user => "username"
password => "aaaaa"
ca_file => "/etc/logstash/elastcertsipdns/ca/" # HERE needs to be a file
query_template => "/usr/share/logstash/templates/capPlan.json"
index => "caplan"
fields => {
"totalSizeInBytes" => "[staleSizeInBytes]"
}
}

1 Like

Thank You.... It works

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.