Unrecognized VM option 'UseConcMarkSweepGC'

C:\elastic_stack\logstash-7.11.1-windows-x86_64\logstash-7.11.1\bin>logstash -f logstash-simple.conf
Using JAVA_HOME defined java: C:\Program Files\Java\jdk-15.0.2
WARNING, using JAVA_HOME while Logstash distribution comes with a bundled JDK
Unrecognized VM option 'UseConcMarkSweepGC'
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

Java 15 is not supported. You can edit the jvm.options file and try it anyway, or unset JAVA_HOME to use the bundled JDK.

can you guide me how to do that steps.. I am zero in java or its options..

I added exception seeing github but now getting below:

C:\elastic_stack\logstash-7.11.1-windows-x86_64\logstash-7.11.1\bin>logstash -f logstash-simple.conf
Using JAVA_HOME defined java: C:\Program Files\Java\jdk-15.0.2
WARNING, using JAVA_HOME while Logstash distribution comes with a bundled JDK
Sending Logstash logs to C:/elastic_stack/logstash-7.11.1-windows-x86_64/logstash-7.11.1/logs which is now configured via log4j2.properties
2021-02-21 04:10:01,262 main ERROR No ScriptEngine found for language JavaScript. Available languages are: ruby, jruby
2021-02-21 04:10:01,293 main ERROR No ScriptEngine found for language JavaScript. Available languages are: ruby, jruby
2021-02-21 04:10:01,426 main ERROR No ScriptEngine found for language JavaScript. Available languages are: ruby, jruby
[2021-02-21T04:10:01,488][INFO ][logstash.runner ] Starting Logstash {"logstash.version"=>"7.11.1", "jruby.version"=>"jruby 9.2.13.0 (2.5.7) 2020-08-03 9a89c94bcc Java HotSpot(TM) 64-Bit Server VM 15.0.2+7-27 on 15.0.2+7-27 +indy +jit [mswin32-x86_64]"}
[2021-02-21T04:10:01,645][WARN ][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[2021-02-21T04:10:03,090][INFO ][logstash.config.source.local.configpathloader] No config files found in path {:path=>"C:/elastic_stack/logstash-7.11.1-windows-x86_64/logstash-7.11.1/bin/logstash-simple.conf"}
[2021-02-21T04:10:03,109][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.
[2021-02-21T04:10:03,827][INFO ][logstash.agent ] Successfully started Logstash API endpoint {:port=>9600}
[2021-02-21T04:10:08,514][INFO ][logstash.runner ] Logstash shut down.
[2021-02-21T04:10:08,795][FATAL][org.logstash.Logstash ] Logstash stopped processing because of an error: (SystemExit) exit
org.jruby.exceptions.SystemExit: (SystemExit) exit
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:747) ~[jruby-complete-9.2.13.0.jar:?]
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:710) ~[jruby-complete-9.2.13.0.jar:?]
at C_3a_.elastic_stack.logstash_minus_7_dot_11_dot_1_minus_windows_minus_x86_64.logstash_minus_7_dot_11_dot_1.lib.bootstrap.environment.(C:\elastic_stack\logstash-7.11.1-windows-x86_64\logstash-7.11.1\lib\bootstrap\environment.rb:89) ~[?:?]

As I said, Java 15 is not supported, so I am not going to address how it fails. Unset JAVA_HOME before running logstash.

If i unset java_home will it not affect elasticsearch and kibana which are already running well?

Elasticsearch supports Java 15 so there is no need to unset JAVA_HOME for that. Just unset it for logstash.

Thank you.. Java issue fixed but some new issue now:

C:\elastic_stack\logstash-7.11.1-windows-x86_64\logstash-7.11.1\bin>logstash -f logstash-simple.conf
"Using bundled JDK: ""
Sending Logstash logs to C:/elastic_stack/logstash-7.11.1-windows-x86_64/logstash-7.11.1/logs which is now configured via log4j2.properties
[2021-02-21T04:38:41,374][INFO ][logstash.runner ] Starting Logstash {"logstash.version"=>"7.11.1", "jruby.version"=>"jruby 9.2.13.0 (2.5.7) 2020-08-03 9a89c94bcc OpenJDK 64-Bit Server VM 11.0.8+10 on 11.0.8+10 +indy +jit [mswin32-x86_64]"}
[2021-02-21T04:38:42,717][WARN ][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[2021-02-21T04:38:44,359][INFO ][logstash.config.source.local.configpathloader] No config files found in path {:path=>"C:/elastic_stack/logstash-7.11.1-windows-x86_64/logstash-7.11.1/bin/logstash-simple.conf"}
[2021-02-21T04:38:44,407][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.
[2021-02-21T04:38:45,219][INFO ][logstash.agent ] Successfully started Logstash API endpoint {:port=>9600}
[2021-02-21T04:38:50,572][INFO ][logstash.runner ] Logstash shut down.
[2021-02-21T04:38:51,788][FATAL][org.logstash.Logstash ] Logstash stopped processing because of an error: (SystemExit) exit
org.jruby.exceptions.SystemExit: (SystemExit) exit
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:747) ~[jruby-complete-9.2.13.0.jar:?]
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:710) ~[jruby-complete-9.2.13.0.jar:?]
at C_3a_.elastic_stack.logstash_minus_7_dot_11_dot_1_minus_windows_minus_x86_64.logstash_minus_7_dot_11_dot_1.lib.bootstrap.environment.(C:\elastic_stack\logstash-7.11.1-windows-x86_64\logstash-7.11.1\lib\bootstrap\environment.rb:89) ~[?:?]

i am using this inside conf file for logstash:

input { stdin { } }
output {
elasticsearch { hosts => ["localhost:9200"] }
stdout { codec => rubydebug }
}

You are running logstash in C:\elastic_stack\logstash-7.11.1-windows-x86_64\logstash-7.11.1\bin, and telling it to use the configuration file logstash-simple.conf, so it looks for the file in that directory, and it does not exist. Use the full path to the configuration file for the -f option.

thank you very much. It was actually spelling mistake. Thank you very much. removing java path, reboot fixed the issue. I used config from here Configuring Logstash | Logstash Reference [7.11] | Elastic

Also I new, pls suggest what can i do next to learn as a cyber security analyst. thanks once again.