Unresolved dependency for elasticsearch-spark


(Pisfly) #1

Hi,

Maybe it's a noob question sorry for that. I'm quite new to spark. I try to use elasticsearch-spark but so far coulnd't get the dependencies in project. Here is the build.scala file, I tried several versions but still no luck. Do I miss some resolver?

  resolvers ++= Seq(
  "Typesafe Repository" at "http://repo.typesafe.com/typesafe/releases/",
  "spray repo" at "http://repo.spray.io",
  "Typesafe Releases" at "http://repo.typesafe.com/typesafe/releases/",
  "clojars" at "https://clojars.org/repo",
  "conjars" at "http://conjars.org/repo",
  "Sonatype" at "http://oss.sonatype.org/content/repositories/snapshots"
),

//
//  Common dependencies for each sub project, put project specific dependencies should move
//  into build.sbt for each project
//

libraryDependencies ++= Seq(
  // spark core
  "org.apache.spark" %% "spark-core" % "2.0.2",
  "org.elasticsearch" % "elasticsearch-spark_2.10" % "2.3.4",

  // testing
  "org.scalatest" %% "scalatest" % "3.0.0" % "test",

  // logging
  "org.apache.logging.log4j" % "log4j-api" % "2.4.1",
  "org.apache.logging.log4j" % "log4j-core" % "2.4.1"
)

)


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.