Update dataset import to use bulk api now all the documents are nested under a doc field


(Jef Statham) #1

I switched up my importing of a csv file from doing single inserts to a
bulk insert but I'm not sure why all my document are nested in a doc field
instead of inserted as value. There is no 'doc' field in the dataset so I'm
not sure where that value is coming from.
ie:

"hits": [
{
"_index": "sample-index",
"_type": "sample_agg1_v3",
"_id": "75a6c925-d37e-49fd-b1ca-3c5355e2d146",
"_score": 1,
"_source": {
"doc": "{' ............. the data

instead of

"hits": [
{
"_index": "sample-index",
"_type": "agg1_sample",
"_id": "83abd750-54d9-4373-8710-5eff29485c9e",
"_score": 1,
"_source": { .... the data

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b5120d5f-083b-407f-8571-db3328be3621%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #2