Upgrade elasticsearch to 0.90.5 from 0.90.2 having problem


(unixdbasvc) #1

When I upgrade elasticsearch from 0.90.2 to 0.90.5, it cannot start. The
cluster status is always red. What I did is just shutdown 0.90.2 and
copy/move the data directory to 0.90.5's data directory. Everything else
stays the same. However, the cluster cannot start to green. Starting
using 0.90.2 is fine. Anyone had the same problem? (config file is the
same) Thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

Anything relevant in logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 3 oct. 2013 à 08:48, unixdbasvc@gmail.com a écrit :

When I upgrade elasticsearch from 0.90.2 to 0.90.5, it cannot start. The cluster status is always red. What I did is just shutdown 0.90.2 and copy/move the data directory to 0.90.5's data directory. Everything else stays the same. However, the cluster cannot start to green. Starting using 0.90.2 is fine. Anyone had the same problem? (config file is the same) Thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Brian Yoder) #3

I'm a little late to this, but we point the data path to a different
location that the code installation path. Then there's no moving. For
example:

/rootpath/code-path/elasticsearch/...
/rootpath/esdb

Then code version installations from 0.19.4 to 0.19.11 to 0.20.4 to 0.90.0
to 0.90.3 (haven't gone to .5 yet) have not moved or even disturbed the
data within that second path. And for some of our servers, there exist
documents that was originally loaded by 0.19.4 and then updated by all of
the subsequent versions without any functional issues.

It's rather analogous to keeping /home on a separate filesystem so when you
reformat and reinstall the OS, your /home directories are not modified.

Brian

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(unixdbasvc) #4

Hi David, Yes, the log file shows:

[2013-10-03 07:51:19,495][INFO ][node ] [node1] started
[2013-10-03 07:51:20,519][WARN ][indices.cluster ] [node1] [32]
failed to add mapping [model_document], source [{"model_doc
ument":{"properties":{"_type":{"type":"string"},"attachment__mdremote_attachment":{"type":"remote_attachment","path":"full","fields"
:{"attachment__mdremote_attachment":{"type":"string"},"author":{"type":"string"},"title":{"type":"string"},"name":{"type":"string"},
"date":{"type":"date","format":"dateOptionalTime"},"keywords":{"type":"string"},"content_type":{"type":"string"}}},"attachment__mdre
mote_attachment_sort":{"type":"remote_attachment","path":"full","fields":{"attachment__mdremote_attachment_sort":{"type":"string"},"
author":{"type":"string"},"title":{"type":"string"},"name":{"type":"string"},"date":{"type":"date","format":"dateOptionalTime"},"key
words":{"type":"string"},"content_type":{"type":"string"}}},"created_at__mdd":{"type":"date","format":"dateOptionalTime","include_in
all":false},"created_at__mdd_sort":{"type":"date","format":"dateOptionalTime","include_in_all":false},"created_by_id__mdr":{"type":
"integer","include_in_all":false},"created_by_id__mdr_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"doc_labe
l__mds":{"type":"string","include_in_all":false},"doc_label__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false
},"document_content_type__mds":{"type":"string","include_in_all":false},"document_content_type__mds_sort":{"type":"string","analyzer
":"sortable","include_in_all":false},"document_description__mds":{"type":"string","include_in_all":false},"document_description__mds
sort":{"type":"string","analyzer":"sortable","include_in_all":false},"document_file_name__mds":{"type":"string","include_in_all":tr
ue},"document_file_name__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"document_file_size__mdi":{"type":
"integer","include_in_all":false},"document_file_size__mdi_sort":{"type":"integer","include_in_all":false},"document_text__mds":{"ty
pe":"string","include_in_all":true},"document_text__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"docume
nt_type__mds":{"type":"string","include_in_all":false},"document_type__mds_sort":{"type":"string","analyzer":"sortable","include_in

all":false},"document_updated_at__mdd":{"type":"date","format":"dateOptionalTime","include_in_all":false},"document_updated_at__mdd

sort":{"type":"date","format":"dateOptionalTime","include_in_all":false},"documentable_id__mdi":{"type":"integer","include_in_all":f
alse},"documentable_id__mdi_sort":{"type":"integer","include_in_all":false},"documentable_type__mds":{"type":"string","include_in_al
l":false},"documentable_type__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"icon_url__mds":{"type":"stri
ng","include_in_all":false},"icon_url__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"id__mdi":{"type":"i
nteger","include_in_all":false},"id__mdi_sort":{"type":"integer","include_in_all":false},"migrate_id__mdi":{"type":"integer","includ
e_in_all":false},"migrate_id__mdi_sort":{"type":"integer","include_in_all":false},"migrate_source_name__mds":{"type":"string","inclu
de_in_all":false},"migrate_source_name__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"model_document_tem
plate_id__mdr":{"type":"integer","include_in_all":false},"model_document_template_id__mdr_sort":{"type":"string","analyzer":"sortabl
e","include_in_all":false},"model_document_type_id__mdr":{"type":"integer","include_in_all":false},"model_document_type_id__mdr_sort
":{"type":"string","analyzer":"sortable","include_in_all":false},"model_theme_id__mdr":{"type":"integer","include_in_all":false},"mo
del_theme_id__mdr_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"s3_permission__mds":{"type":"string","includ
e_in_all":false},"s3_permission__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"updated_at__mdd":{"type":
"date","format":"dateOptionalTime","include_in_all":false},"updated_at__mdd_sort":{"type":"date","format":"dateOptionalTime","includ
e_in_all":false},"updated_by_id__mdr":{"type":"integer","include_in_all":false},"updated_by_id__mdr_sort":{"type":"string","analyzer
":"sortable","include_in_all":false},"url__mds":{"type":"string","include_in_all":false},"url__mds_sort":{"type":"string","analyzer"
:"sortable","include_in_all":false}}}}]
org.elasticsearch.index.mapper.MapperParsingException: No handler for type
[remote_attachment] declared on field [attachment__mdremo
te_attachment]
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parseProperties(ObjectMapper.java:261)
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parse(ObjectMapper.java:219)
at
org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:177)
at
org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:387)
at
org.elasticsearch.index.mapper.MapperService.merge(MapperService.java:195)
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.processMapping(IndicesClusterStateService.java:398)
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.applyMappings(IndicesClusterStateService.java:364)
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.clusterChanged(IndicesClusterStateService.java:177)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:395)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEs
ThreadPoolExecutor.java:135)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown
Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown
Source)
at java.lang.Thread.run(Unknown Source)

On Wednesday, October 2, 2013 11:48:54 PM UTC-7, unixd...@gmail.com wrote:

When I upgrade elasticsearch from 0.90.2 to 0.90.5, it cannot start. The
cluster status is always red. What I did is just shutdown 0.90.2 and
copy/move the data directory to 0.90.5's data directory. Everything else
stays the same. However, the cluster cannot start to green. Starting
using 0.90.2 is fine. Anyone had the same problem? (config file is the
same) Thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #5

remote_attachment is not an existing elasticsearch type, right?
Did you create a plugin or something?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 3 oct. 2013 à 16:52, unixdbasvc@gmail.com a écrit :

Hi David, Yes, the log file shows:

[2013-10-03 07:51:19,495][INFO ][node ] [node1] started
[2013-10-03 07:51:20,519][WARN ][indices.cluster ] [node1] [32] failed to add mapping [model_document], source [{"model_doc
ument":{"properties":{"_type":{"type":"string"},"attachment__mdremote_attachment":{"type":"remote_attachment","path":"full","fields"
:{"attachment__mdremote_attachment":{"type":"string"},"author":{"type":"string"},"title":{"type":"string"},"name":{"type":"string"},
"date":{"type":"date","format":"dateOptionalTime"},"keywords":{"type":"string"},"content_type":{"type":"string"}}},"attachment__mdre
mote_attachment_sort":{"type":"remote_attachment","path":"full","fields":{"attachment__mdremote_attachment_sort":{"type":"string"},"
author":{"type":"string"},"title":{"type":"string"},"name":{"type":"string"},"date":{"type":"date","format":"dateOptionalTime"},"key
words":{"type":"string"},"content_type":{"type":"string"}}},"created_at__mdd":{"type":"date","format":"dateOptionalTime","include_in
all":false},"created_at__mdd_sort":{"type":"date","format":"dateOptionalTime","include_in_all":false},"created_by_id__mdr":{"type":
"integer","include_in_all":false},"created_by_id__mdr_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"doc_labe
l__mds":{"type":"string","include_in_all":false},"doc_label__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false
},"document_content_type__mds":{"type":"string","include_in_all":false},"document_content_type__mds_sort":{"type":"string","analyzer
":"sortable","include_in_all":false},"document_description__mds":{"type":"string","include_in_all":false},"document_description__mds
sort":{"type":"string","analyzer":"sortable","include_in_all":false},"document_file_name__mds":{"type":"string","include_in_all":tr
ue},"document_file_name__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"document_file_size__mdi":{"type":
"integer","include_in_all":false},"document_file_size__mdi_sort":{"type":"integer","include_in_all":false},"document_text__mds":{"ty
pe":"string","include_in_all":true},"document_text__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"docume
nt_type__mds":{"type":"string","include_in_all":false},"document_type__mds_sort":{"type":"string","analyzer":"sortable","include_in

all":false},"document_updated_at__mdd":{"type":"date","format":"dateOptionalTime","include_in_all":false},"document_updated_at__mdd

sort":{"type":"date","format":"dateOptionalTime","include_in_all":false},"documentable_id__mdi":{"type":"integer","include_in_all":f
alse},"documentable_id__mdi_sort":{"type":"integer","include_in_all":false},"documentable_type__mds":{"type":"string","include_in_al
l":false},"documentable_type__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"icon_url__mds":{"type":"stri
ng","include_in_all":false},"icon_url__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"id__mdi":{"type":"i
nteger","include_in_all":false},"id__mdi_sort":{"type":"integer","include_in_all":false},"migrate_id__mdi":{"type":"integer","includ
e_in_all":false},"migrate_id__mdi_sort":{"type":"integer","include_in_all":false},"migrate_source_name__mds":{"type":"string","inclu
de_in_all":false},"migrate_source_name__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"model_document_tem
plate_id__mdr":{"type":"integer","include_in_all":false},"model_document_template_id__mdr_sort":{"type":"string","analyzer":"sortabl
e","include_in_all":false},"model_document_type_id__mdr":{"type":"integer","include_in_all":false},"model_document_type_id__mdr_sort
":{"type":"string","analyzer":"sortable","include_in_all":false},"model_theme_id__mdr":{"type":"integer","include_in_all":false},"mo
del_theme_id__mdr_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"s3_permission__mds":{"type":"string","includ
e_in_all":false},"s3_permission__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"updated_at__mdd":{"type":
"date","format":"dateOptionalTime","include_in_all":false},"updated_at__mdd_sort":{"type":"date","format":"dateOptionalTime","includ
e_in_all":false},"updated_by_id__mdr":{"type":"integer","include_in_all":false},"updated_by_id__mdr_sort":{"type":"string","analyzer
":"sortable","include_in_all":false},"url__mds":{"type":"string","include_in_all":false},"url__mds_sort":{"type":"string","analyzer"
:"sortable","include_in_all":false}}}}]
org.elasticsearch.index.mapper.MapperParsingException: No handler for type [remote_attachment] declared on field [attachment__mdremo
te_attachment]
at org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parseProperties(ObjectMapper.java:261)
at org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parse(ObjectMapper.java:219)
at org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:177)
at org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:387)
at org.elasticsearch.index.mapper.MapperService.merge(MapperService.java:195)
at org.elasticsearch.indices.cluster.IndicesClusterStateService.processMapping(IndicesClusterStateService.java:398)
at org.elasticsearch.indices.cluster.IndicesClusterStateService.applyMappings(IndicesClusterStateService.java:364)
at org.elasticsearch.indices.cluster.IndicesClusterStateService.clusterChanged(IndicesClusterStateService.java:177)
at org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:395)
at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEs
ThreadPoolExecutor.java:135)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

On Wednesday, October 2, 2013 11:48:54 PM UTC-7, unixd...@gmail.com wrote:
When I upgrade elasticsearch from 0.90.2 to 0.90.5, it cannot start. The cluster status is always red. What I did is just shutdown 0.90.2 and copy/move the data directory to 0.90.5's data directory. Everything else stays the same. However, the cluster cannot start to green. Starting using 0.90.2 is fine. Anyone had the same problem? (config file is the same) Thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ivan Brusic) #6

Did you previously add the attachment plugin, but not reinstall it for the
new version?

BTW, you should not have to copy the data between installations. Have the
data in an install-neutral location and reference it via the path.data
variable.

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup-dir-layout.html

Cheers,

Ivan

On Thu, Oct 3, 2013 at 7:52 AM, unixdbasvc@gmail.com wrote:

Hi David, Yes, the log file shows:

[2013-10-03 07:51:19,495][INFO ][node ] [node1] started
[2013-10-03 07:51:20,519][WARN ][indices.cluster ] [node1] [32]
failed to add mapping [model_document], source [{"model_doc

ument":{"properties":{"_type":{"type":"string"},"attachment__mdremote_attachment":{"type":"remote_attachment","path":"full","fields"

:{"attachment__mdremote_attachment":{"type":"string"},"author":{"type":"string"},"title":{"type":"string"},"name":{"type":"string"},

"date":{"type":"date","format":"dateOptionalTime"},"keywords":{"type":"string"},"content_type":{"type":"string"}}},"attachment__mdre

mote_attachment_sort":{"type":"remote_attachment","path":"full","fields":{"attachment__mdremote_attachment_sort":{"type":"string"},"

author":{"type":"string"},"title":{"type":"string"},"name":{"type":"string"},"date":{"type":"date","format":"dateOptionalTime"},"key

words":{"type":"string"},"content_type":{"type":"string"}}},"created_at__mdd":{"type":"date","format":"dateOptionalTime","include_in

_all":false},"created_at__mdd_sort":{"type":"date","format":"dateOptionalTime","include_in_all":false},"created_by_id__mdr":{"type":

"integer","include_in_all":false},"created_by_id__mdr_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"doc_labe

l__mds":{"type":"string","include_in_all":false},"doc_label__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false

},"document_content_type__mds":{"type":"string","include_in_all":false},"document_content_type__mds_sort":{"type":"string","analyzer

":"sortable","include_in_all":false},"document_description__mds":{"type":"string","include_in_all":false},"document_description__mds

_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"document_file_name__mds":{"type":"string","include_in_all":tr

ue},"document_file_name__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"document_file_size__mdi":{"type":

"integer","include_in_all":false},"document_file_size__mdi_sort":{"type":"integer","include_in_all":false},"document_text__mds":{"ty

pe":"string","include_in_all":true},"document_text__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"docume

nt_type__mds":{"type":"string","include_in_all":false},"document_type__mds_sort":{"type":"string","analyzer":"sortable","include_in_

all":false},"document_updated_at__mdd":{"type":"date","format":"dateOptionalTime","include_in_all":false},"document_updated_at__mdd_

sort":{"type":"date","format":"dateOptionalTime","include_in_all":false},"documentable_id__mdi":{"type":"integer","include_in_all":f

alse},"documentable_id__mdi_sort":{"type":"integer","include_in_all":false},"documentable_type__mds":{"type":"string","include_in_al

l":false},"documentable_type__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"icon_url__mds":{"type":"stri

ng","include_in_all":false},"icon_url__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"id__mdi":{"type":"i

nteger","include_in_all":false},"id__mdi_sort":{"type":"integer","include_in_all":false},"migrate_id__mdi":{"type":"integer","includ

e_in_all":false},"migrate_id__mdi_sort":{"type":"integer","include_in_all":false},"migrate_source_name__mds":{"type":"string","inclu

de_in_all":false},"migrate_source_name__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"model_document_tem

plate_id__mdr":{"type":"integer","include_in_all":false},"model_document_template_id__mdr_sort":{"type":"string","analyzer":"sortabl

e","include_in_all":false},"model_document_type_id__mdr":{"type":"integer","include_in_all":false},"model_document_type_id__mdr_sort

":{"type":"string","analyzer":"sortable","include_in_all":false},"model_theme_id__mdr":{"type":"integer","include_in_all":false},"mo

del_theme_id__mdr_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"s3_permission__mds":{"type":"string","includ

e_in_all":false},"s3_permission__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"updated_at__mdd":{"type":

"date","format":"dateOptionalTime","include_in_all":false},"updated_at__mdd_sort":{"type":"date","format":"dateOptionalTime","includ

e_in_all":false},"updated_by_id__mdr":{"type":"integer","include_in_all":false},"updated_by_id__mdr_sort":{"type":"string","analyzer

":"sortable","include_in_all":false},"url__mds":{"type":"string","include_in_all":false},"url__mds_sort":{"type":"string","analyzer"
:"sortable","include_in_all":false}}}}]
org.elasticsearch.index.mapper.MapperParsingException: No handler for type
[remote_attachment] declared on field [attachment__mdremo
te_attachment]
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parseProperties(ObjectMapper.java:261)
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parse(ObjectMapper.java:219)
at
org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:177)
at
org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:387)
at
org.elasticsearch.index.mapper.MapperService.merge(MapperService.java:195)
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.processMapping(IndicesClusterStateService.java:398)
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.applyMappings(IndicesClusterStateService.java:364)
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.clusterChanged(IndicesClusterStateService.java:177)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:395)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEs
ThreadPoolExecutor.java:135)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown
Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown
Source)
at java.lang.Thread.run(Unknown Source)

On Wednesday, October 2, 2013 11:48:54 PM UTC-7, unixd...@gmail.com wrote:

When I upgrade elasticsearch from 0.90.2 to 0.90.5, it cannot start. The
cluster status is always red. What I did is just shutdown 0.90.2 and
copy/move the data directory to 0.90.5's data directory. Everything else
stays the same. However, the cluster cannot start to green. Starting
using 0.90.2 is fine. Anyone had the same problem? (config file is the
same) Thanks!

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ivan Brusic) #7

David and I responded at the same time. I never used the attachment plugin,
so I assumed the handler in question was said plugin. Apparently not, but
the scenario could still remain: did you have plugins installed on the old
version that are not present in the new one?

Cheers,

Ivan

On Thu, Oct 3, 2013 at 8:09 AM, David Pilato david@pilato.fr wrote:

remote_attachment is not an existing elasticsearch type, right?
Did you create a plugin or something?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 3 oct. 2013 à 16:52, unixdbasvc@gmail.com a écrit :

Hi David, Yes, the log file shows:

[2013-10-03 07:51:19,495][INFO ][node ] [node1] started
[2013-10-03 07:51:20,519][WARN ][indices.cluster ] [node1] [32]
failed to add mapping [model_document], source [{"model_doc

ument":{"properties":{"_type":{"type":"string"},"attachment__mdremote_attachment":{"type":"remote_attachment","path":"full","fields"

:{"attachment__mdremote_attachment":{"type":"string"},"author":{"type":"string"},"title":{"type":"string"},"name":{"type":"string"},

"date":{"type":"date","format":"dateOptionalTime"},"keywords":{"type":"string"},"content_type":{"type":"string"}}},"attachment__mdre

mote_attachment_sort":{"type":"remote_attachment","path":"full","fields":{"attachment__mdremote_attachment_sort":{"type":"string"},"

author":{"type":"string"},"title":{"type":"string"},"name":{"type":"string"},"date":{"type":"date","format":"dateOptionalTime"},"key

words":{"type":"string"},"content_type":{"type":"string"}}},"created_at__mdd":{"type":"date","format":"dateOptionalTime","include_in

_all":false},"created_at__mdd_sort":{"type":"date","format":"dateOptionalTime","include_in_all":false},"created_by_id__mdr":{"type":

"integer","include_in_all":false},"created_by_id__mdr_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"doc_labe

l__mds":{"type":"string","include_in_all":false},"doc_label__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false

},"document_content_type__mds":{"type":"string","include_in_all":false},"document_content_type__mds_sort":{"type":"string","analyzer

":"sortable","include_in_all":false},"document_description__mds":{"type":"string","include_in_all":false},"document_description__mds

_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"document_file_name__mds":{"type":"string","include_in_all":tr

ue},"document_file_name__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"document_file_size__mdi":{"type":

"integer","include_in_all":false},"document_file_size__mdi_sort":{"type":"integer","include_in_all":false},"document_text__mds":{"ty

pe":"string","include_in_all":true},"document_text__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"docume

nt_type__mds":{"type":"string","include_in_all":false},"document_type__mds_sort":{"type":"string","analyzer":"sortable","include_in_

all":false},"document_updated_at__mdd":{"type":"date","format":"dateOptionalTime","include_in_all":false},"document_updated_at__mdd_

sort":{"type":"date","format":"dateOptionalTime","include_in_all":false},"documentable_id__mdi":{"type":"integer","include_in_all":f

alse},"documentable_id__mdi_sort":{"type":"integer","include_in_all":false},"documentable_type__mds":{"type":"string","include_in_al

l":false},"documentable_type__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"icon_url__mds":{"type":"stri

ng","include_in_all":false},"icon_url__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"id__mdi":{"type":"i

nteger","include_in_all":false},"id__mdi_sort":{"type":"integer","include_in_all":false},"migrate_id__mdi":{"type":"integer","includ

e_in_all":false},"migrate_id__mdi_sort":{"type":"integer","include_in_all":false},"migrate_source_name__mds":{"type":"string","inclu

de_in_all":false},"migrate_source_name__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"model_document_tem

plate_id__mdr":{"type":"integer","include_in_all":false},"model_document_template_id__mdr_sort":{"type":"string","analyzer":"sortabl

e","include_in_all":false},"model_document_type_id__mdr":{"type":"integer","include_in_all":false},"model_document_type_id__mdr_sort

":{"type":"string","analyzer":"sortable","include_in_all":false},"model_theme_id__mdr":{"type":"integer","include_in_all":false},"mo

del_theme_id__mdr_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"s3_permission__mds":{"type":"string","includ

e_in_all":false},"s3_permission__mds_sort":{"type":"string","analyzer":"sortable","include_in_all":false},"updated_at__mdd":{"type":

"date","format":"dateOptionalTime","include_in_all":false},"updated_at__mdd_sort":{"type":"date","format":"dateOptionalTime","includ

e_in_all":false},"updated_by_id__mdr":{"type":"integer","include_in_all":false},"updated_by_id__mdr_sort":{"type":"string","analyzer

":"sortable","include_in_all":false},"url__mds":{"type":"string","include_in_all":false},"url__mds_sort":{"type":"string","analyzer"
:"sortable","include_in_all":false}}}}]
org.elasticsearch.index.mapper.MapperParsingException: No handler for type
[remote_attachment] declared on field [attachment__mdremo
te_attachment]
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parseProperties(ObjectMapper.java:261)
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parse(ObjectMapper.java:219)
at
org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:177)
at
org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:387)
at
org.elasticsearch.index.mapper.MapperService.merge(MapperService.java:195)
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.processMapping(IndicesClusterStateService.java:398)
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.applyMappings(IndicesClusterStateService.java:364)
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.clusterChanged(IndicesClusterStateService.java:177)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:395)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEs
ThreadPoolExecutor.java:135)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown
Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown
Source)
at java.lang.Thread.run(Unknown Source)

On Wednesday, October 2, 2013 11:48:54 PM UTC-7, unixd...@gmail.com wrote:

When I upgrade elasticsearch from 0.90.2 to 0.90.5, it cannot start. The
cluster status is always red. What I did is just shutdown 0.90.2 and
copy/move the data directory to 0.90.5's data directory. Everything else
stays the same. However, the cluster cannot start to green. Starting
using 0.90.2 is fine. Anyone had the same problem? (config file is the
same) Thanks!

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(unixdbasvc) #8

Thanks everyone who replied. It seems working now somehow. I may have
messed up the config file but I cannot recall now. Really appreciate
everyone's input to give me some direction where to look.

On Wednesday, October 2, 2013 11:48:54 PM UTC-7, unixd...@gmail.com wrote:

When I upgrade elasticsearch from 0.90.2 to 0.90.5, it cannot start. The
cluster status is always red. What I did is just shutdown 0.90.2 and
copy/move the data directory to 0.90.5's data directory. Everything else
stays the same. However, the cluster cannot start to green. Starting
using 0.90.2 is fine. Anyone had the same problem? (config file is the
same) Thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #9