Upgrade from 1.2.1 to 1.4.2 and indices/shards corrupted


We upgraded from 1.2.1 to 1.4.2 and after the restart, some shards were in
UNASSIGNED state because they was corrupted.
Here is a log: https://gist.github.com/anonymous/63a0e3f70a72bab37052 and
"Failed to start shard, message
[IndexShardGatewayRecoveryException[[events_xxxxx][2] failed to fetch index
version after copying it over]"

To solve this, we deleted _checksums and corrupted* files from the data

After various node restart... some shard which were perfectly loaded
previously became suddenly "Corrupted"... The problem occured also when i
tried to increase the number of replica on an index with no replica. The
primary and the replica became UNASSIGNED for the same reason.

I tried the command to force allocation but without success: trying to
allocate a primary shard [events_xxxx][2], which is disabled
And i can't consider to set allow_primary="true" if i lose my data. cf doc
"might result in data loss". In which case there is no data loss ?

The cluster is now green but.. i'm afraid to restart it or to add replica
to others indices.

Any idea about this issue ?

Thank you for you help

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0ba1ce67-c220-42cd-8df9-fafde50970e5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.