Upgrade the Elasticsearch to 7.10 version warning

I have a elasticsearch cluster about 6 node(3 masters , 3 data,the version is 6.6, running through the docker), and then, I want to upgrade it from 6.6 to 7.10 , accronding to the Official document , I must upgrade my cluster to 6.8 first , and then upgrade to 7.10. I did these steps, and final the cluster upgrade is ok , but I found that have some warning logs in the version 7.10:
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation.
SLF4J: See SLF4J Error Codes for further details.

I think it maybe impact my cluster‘s status logs, because I test that: I stop a node elasitcsearch , and the master's log just out put the log for shard, no log to the node for leave the cluster ,and then the stopped elasticsearch node is starting , there is also no logs for the node join into the cluster in the master node logs. Is that normal for the cluster?

how can I fix this issue?

I have another test, when I upgrade the 6.6 to 6.8, the elasticsearch node has also have this warning.

What kind of upgrade did you try?
What exact steps did you run?

I use the rolling upgrade node one by one. Before I upgrade the cluster, I just setting the cluster:
PUT _cluster/settings
"persistent": {
"cluster": {
"routing": {
"allocation.enable": "none"

And then change the docker images from 6.6 to 6.8

How do you run the instance exactly?

Please format your code, logs or configuration files using </> icon as explained in this guide and not the citation button. It will make your post more readable.

Or use markdown style like:


This is the icon to use if you are not using markdown format:

There's a live preview panel for exactly this reasons.

Lots of people read these forums, and many of them will simply skip over a post that is difficult to read, because it's just too large an investment of their time to try and follow a wall of badly formatted text.
If your goal is to get an answer to your questions, it's in your interest to make it as easy to read and understand as possible.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.