Upgrade to 6.2 fails on Win 10


(Ian Campbell) #1

I downloaded the MSI and attempted to install 6.2. I have 6.0 installed. I get the attached error moments after running the MSI.

I'm running Win 10 Home 64-bit with all patches.

2


(Russ Cam) #2

Are there any related entries in the Event log @IanRC72?


(Ian Campbell) #3

Two entries (I ran the installation twice with the same error message each time):

Product: Elasticsearch 6.2.0 -- Installation failed.

Windows Installer installed the product. Product Name: Elasticsearch 6.2.0. Product Version: 6.2.0. Product Language: 1033. Manufacturer: Elastic. Installation success or error status: 1603.

A check of Services reveals 6.0 is installed.


(Russ Cam) #4

OK, the 6.2.0 installer is running from what I can see.

At what point do you see the attached screenshot? Does the 6.2.0 UI load correctly?

A log file for the installation process can be found within the %TEMP% directory, with a randomly generated name adhering to the format MSI<random>.LOG. If the installer is the last process to run with msiexec.exe, then the log file for the failed installation will be the most recent log file. If you could add that file here, or post as a gist and link to it, it may provide more details.


(Ian Campbell) #5

The usual "Preparing to install..." windows pops up. A second later, the error occurs.

Here's the log file.

Thanks.


(Russ Cam) #6

Looks like an issue with the initialization of the Embedded WPF UI.

Would you mind trying the 6.2.1 MSI and seeing if you have the same issue?


(Ian Campbell) #7

I tried 6.2.1 but it gives the same error message in the same manner. Rebooted and tried again.

Here's the log file.


(Martijn Laarman) #8

Do you have any anti virus software running on the machine @IanRC72?


(Ian Campbell) #9

Bitdefender 2018. It was running when I installed 6.0. I disabled it but the installation gave the same error.


(system) #10

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.