Upgrade to x-pack failure, cannot set passwords


#1

Per the opening of x-pack, I've tried to upgrade to it with my current cluster. I perhaps did not do enough research into what's involved but here I am.
I have a trial license and ES version 6.1.

Here's what I did:

  • Disabled shard routing allocation
  • Performed a sync-flush
  • Set indices to read-only (<-- might be my problem)
  • Stopped elasticsearch on all nodes, installed x-pack
  • Set a bootstrap.password (/usr/share/elasticsearch/bin/elasticsearch-keystore remove bootstrap-password --stdin)
  • Confirmed it was working with an /_xpack/security/_authenticate/ request.
  • /usr/share/elasticsearch/bin/x-pack/setup-passwords interactive timed out after prompting for passwords
  • Basic authentication with bootstrap password now fails.
  • All of the cluster is now down.

Logs I managed to pull without my brain exploding:

Pretty stuck from where to go from here. Am I screwed with my data even if I upgrade to Elastic 6.2? Is the new open version of x-pack only available on 6.3?


(Yogesh Gaikwad) #2

Hi @rmac,

Did you try to upgrade your cluster to 6.3?
The open version of x-pack is available 6.3 onwards.


(Tim Vernum) #3

Your cluster is not in good shape, but hopefully we can get you back up and running.

Note, as @Yogesh_Gaikwad has said, Open X-Pack will only be available in 6.3, and it will come pre-installed so your attempts to install X-Pack aren't going to achieve much.

Also, to be 100% clear, even with the Open X-Pack security is a commercial feature that requires a paid license. We strongly recommend enabling X-Pack security, but unless you purchase a gold or platinum subscription then you'll be limited to a 30 day trial and then need to disable security again.

What we need to do is get you access to your cluster again, so you can then set indices to read-write again and hopefully that will get your cluster back to green.

The simplest step you can take is to simply turn off security while you get things sorted. That will allow you to set the cluster settings back to normal (allow writes, allow allocation) and then you can try to setup passwords again. The bootstrap password process cannot run if your cluster is read-only (and will typically also fail if you disable allocation, but it depends on the exact details).

Add

xpack.security.enabled: false

into your elasticsearch.yml on every node, and restart.
That should resolve your issues. If not, please come back with updated logs.


#4

Thank you very much! Didn't realize the x-pack could be manipulated through elasticsearch.yml, missed that setting in the docs

Is there a reference page in the docs that has all the directives I can declare in elasticsearch.yml for x-pack?

I've also removed x-pack and will wait patiently for 6.3. Sorry for my confusion...


(Tim Vernum) #5

https://www.elastic.co/guide/en/x-pack/6.1/xpack-settings.html

It splits by feature, so there's separate pages for security, monitoring, etc.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.