Upgraded my nodes from 1.7 to 2.0, now my nodes aren't joining cluster


(Ki Song) #1

Hey guys,

I am in a pickle here, I had my 2 node cluster setup working great, but after upgrading my nodes to 2.0 using upgrade instructions, my nodes will not discover when restarted. kopf list only one node (itself) and is yellow on both nodes

Here are my config for my 2 nodes:

node 1 elasticsearch.yml

cluster.name: "avorg"
node.name: "jasper"
index.number_of_shards: 4
index.number_of_replicas: 1
network.publish_host: 54.193.124.xyz
discovery.zen.ping_timeout: 60s
discovery.zen.ping.multicast.enabled: false
discovery.zen.ping.unicast.hosts: ["54.83.199.xyz"]

node 2 elasticsearch.yml

cluster.name: "avorg"
node.name: "sapphire"
index.number_of_shards: 4
index.number_of_replicas: 1
network.publish_host: 54.83.199.xyz
discovery.zen.ping_timeout: 60s
discovery.zen.ping.multicast.enabled: false
discovery.zen.ping.unicast.hosts: ["54.193.124.xyz"]

When I restart jasper node, I can see one unusual exception in the log:

    ClusterBlockException[blocked by: [SERVICE_UNAVAILABLE/1/state not recovered / initialized];]
    	at org.elasticsearch.cluster.block.ClusterBlocks.globalBlockedException(ClusterBlocks.java:154)
    	at org.elasticsearch.action.admin.indices.stats.TransportIndicesStatsAction.checkGlobalBlock(TransportIndicesStatsAction.java:70)

When node 2 starts, the log output same exception.

Any help is appreciated.

Thanks in advance


(Nik Everett) #2

Use network.host instead or network.public_host. In 1.x elasticsearch listened on all interfaces by default. in 2.0 it listens only on network.bind_host by default and that defaults to network.host and that defaults to localhost. So if you set it to 54.193.124.xyz then elasticsearch will both listen to and bind to that interface.

A side effect of this is the curl localhost:9200 won't work, you'll have to curl 54.193.124.xyz now.

This was done as a security measure - the idea being that anytime a service listens on anything other than localhost the operator needs to have made a conscious decision.


(Ki Song) #3

Thank you I believe that solved my problem.


(system) #4