Upgrading from 5.6.12.to 5.6.13 on Fedora 27 - elastic service fails on startup


(Capitals) #1

I have a Fedora 27 server with Elasticsearch 5.6.12, Logstash 5.6.12 and Java JDK 1.8.0-181. Working just fine...

I just upgraded, in 2 seperate VM's, from ElasticSearch 5.6.12. to 5.6.13

VM 1. upgrading with RPM from website (only ElasticSearch 5.6.13)

VM 2. upgrading through Fedora software updates (includes to ElasticSearch 5.6.13, Java JDK 1.8.0-191 and Logstash 5.6.13)

After the upgrade, and after a reboot, the elastic service fails with the same error in both senarios:

/usr/share/elasticsearch/lib/plugin-cli-5.6.13.tar requieres elasticsearch 5.6.13, your system: 5.6.12.

Before sending tons of logs can anyone help me with what this means? Thank you..


(Byron Voorbach) #2

Plugins are built for a specific version. When you upgrade your ES, you'll have to remove all your plugins and reinstall them with the correct version.

It seems from the last line that you're trying to install 5.6.13 plugin onto a 5.6.12 ES, meaning that the upgrade did not succeed. Can you confirm the new version on the machine? It feels like that message should be the other way around though, that you still have 5.6.12 plugin when trying to run 5.6.13


(Capitals) #3

I stopped ES service, renamed /usr/share/elasticsearch to _old, downloaded ES 5.6.13 RPM from elastic.co and updated through software updater, rebooted, checked http://elastic.server:9200 for version 5.6.13 = succes. Ran all updates fro software updates, rebooted and it worked. Thanks for helping.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.