Urgent - No shards assigning


(Aaron Troy) #1

Hi all,

I have a system set up with 12 nodes, 48 indexes, and 12 shards/index (I
know that number is way too high).

Anyways, I'm in the process of indexing all the data onto a new index with
far less shards, but I wanted to keep the initial cluster up for existing
users searching the data. Well, one of the nodes ran out of memory and
locked the system up, so I did a /etc/init.d/elasticsearch restart to each
node. When things came back up, none of the nodes would assigned. There's
absolutely nothing in the log file. It just looks like a normal start-up.
Any idea?

Here's my elasticsearch.yml file:

cluster.name: Odine
node.name: "rap-es"
path.data: /data/elasticsearch/data
path.work: /data/elasticsearch/work
path.logs: /data/elasticsearch/logs
#discovery.zen.minimum_master_nodes: 5
#discovery.zen.ping.multicast.enabled: true
discovery.zen.ping.multicast.enabled: false
discovery.zen.ping.unicast.hosts: ["141.161.88.169:9300",
"141.161.88.174:9300","141.161.88.175:9300","141.161.88.176:9300",
"141.161.88.177:9300","141.161.88.178:9300","141.161.88.179:9300",
"141.161.88.181:9300","141.161.88.182:9300","141.161.88.183:9300",
"141.161.88.184:9300","141.161.88.185:9300","141.161.88.186:9300"]

node.data: false

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8dc54ad9-8606-4793-80c4-fb295ad05a15%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Nik Everett) #2

Doesn't node.data: false mean don't put anydata on this node?

Nik

On Wed, Mar 5, 2014 at 10:54 AM, Aaron Troy atoy3731@gmail.com wrote:

Hi all,

I have a system set up with 12 nodes, 48 indexes, and 12 shards/index (I
know that number is way too high).

Anyways, I'm in the process of indexing all the data onto a new index with
far less shards, but I wanted to keep the initial cluster up for existing
users searching the data. Well, one of the nodes ran out of memory and
locked the system up, so I did a /etc/init.d/elasticsearch restart to each
node. When things came back up, none of the nodes would assigned. There's
absolutely nothing in the log file. It just looks like a normal start-up.
Any idea?

Here's my elasticsearch.yml file:

cluster.name: Odine
node.name: "rap-es"
path.data: /data/elasticsearch/data
path.work: /data/elasticsearch/work
path.logs: /data/elasticsearch/logs
#discovery.zen.minimum_master_nodes: 5
#discovery.zen.ping.multicast.enabled: true
discovery.zen.ping.multicast.enabled: false
discovery.zen.ping.unicast.hosts: ["141.161.88.169:9300","
141.161.88.174:9300","141.161.88.175:9300","141.161.88.176:9300","
141.161.88.177:9300","141.161.88.178:9300","141.161.88.179:9300","
141.161.88.181:9300","141.161.88.182:9300","141.161.88.183:9300","
141.161.88.184:9300","141.161.88.185:9300","141.161.88.186:9300"]

node.data: false

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/8dc54ad9-8606-4793-80c4-fb295ad05a15%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/8dc54ad9-8606-4793-80c4-fb295ad05a15%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAPmjWd1uaDgJYVSfK16etEc4YOBJzgV%2B59pLqx5X827F7n_t4Q%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3