Urgent


(Sekrafi Ismail) #1

Bonjour,

Je viens de travailler sur elasticsearch, j'ai récupéré les données à
partir d'une base de données postgresql mais j'arrive pas de faire la
suppression et la mise à jour des données avec elasticsearch.

Vous avez une idée svp ?

Merci d'avance.

Cordialement.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d62c6697-4b8e-4e63-82ae-4491b3a1e667%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #2

Have you tried the "schedule" setting in JDBC river plugin?

You can also try the feeder mode of the JDBC plugin, combined with cronjob
from your crontab.

Best,

Jörg

2014-06-11 11:27 GMT+02:00 Sekrafi Ismail ismail.sekrafi@gmail.com:

Bonjour,

Je viens de travailler sur elasticsearch, j'ai récupéré les données à
partir d'une base de données postgresql mais j'arrive pas de faire la
suppression et la mise à jour des données avec elasticsearch.

Vous avez une idée svp ?

Merci d'avance.

Cordialement.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d62c6697-4b8e-4e63-82ae-4491b3a1e667%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/d62c6697-4b8e-4e63-82ae-4491b3a1e667%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoGk3PVduAe%2BdGSyfoP4aF9mYQ-0Hy5s1rkKXTc6eetGNQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Sekrafi Ismail) #3

Merci pour votre réponse Jorg Prante.

Oui je l'ai essayé mais ça n'a pas marché ! voila qu'est ce que j'ai mis .

curl -XPUT 'localhost:9200/_river/dossiersexemp/_meta' -d '
{
"type" : "jdbc",
"jdbc" : {

    "index" : "i_dossiersexemp",
    "type" : "t_dossiersexemp",
    "driver" : "postgresql-9.2-1002.jdbc4.jar",
    "url" : "jdbc:postgresql://localhost:5432/alyse",
    "user" : "postgres",
    "password" : "",
    "sql" : "SELECT * FROM dossierexemp",
    "strategy" : "simple",
    "schedule": "0 0-59 0-23 ? * *" }

}'

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b25cd836-a4e8-4481-b93c-c54ff2cd5fae%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #4

Hi Sekrafi,

Please follow some guidelines about this forum:

Some other details could be found here: http://www.elasticsearch.org/help/

Thanks!

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 11 juin 2014 à 14:46:15, Sekrafi Ismail (ismail.sekrafi@gmail.com) a écrit:

Merci pour votre réponse Jorg Prante.

Oui je l'ai essayé mais ça n'a pas marché ! voila qu'est ce que j'ai mis .

curl -XPUT 'localhost:9200/_river/dossiersexemp/_meta' -d '
{
"type" : "jdbc",
"jdbc" : {

    "index" : "i_dossiersexemp",
    "type" : "t_dossiersexemp",
    "driver" : "postgresql-9.2-1002.jdbc4.jar",
    "url" : "jdbc:postgresql://localhost:5432/alyse",
    "user" : "postgres",
    "password" : "",
    "sql" : "SELECT * FROM dossierexemp",
    "strategy" : "simple",
    "schedule": "0 0-59 0-23 ? * *" }

}'

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b25cd836-a4e8-4481-b93c-c54ff2cd5fae%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53985867.74b0dc51.6c21%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Sekrafi Ismail) #5

Thanks* David Pilato*,

I found the solution for delete and select, but it remains that update you
have a solution?

Here is the solution for delete and select :

Delete :

curl -XDELETE 'localhost:9200/i_dossiers/_query?pretty=true' -d ' {"query":
{"term": {"dos_id":"985353",
"dos_sficdos":"1210070141","dos_numpatient":"170879"}}}'

Select :

curl -XGET http://localhost:9200/i_dossiers/_search?pretty=true -d
'{"query":{"term":{"dos_id":"985353"}}}'

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/cbe914ad-909d-494d-9fde-8437a0970595%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #6