URI search not returning results when &fields used

Running into an issue with URI searches not returning expected results
after upgrading from 0.90.9 to 1.4.1

The issue is that subfields are not returned when specified with "&fields".
I have confirmed that the data is there by doing the same search without
the &fields specifications and get the Meter.geometry.coordinates. I am
not seeing anything in the release notes for 1.4.1 that indicate any change
in URI search functionality.

Hoping someone has run into this already and can tell me how to specify
subfields for results sets other than the &fields method or how to get the
&fields method to work again in 1.4.1+

Thanks in advance.

0.90.9 URI Search:
https://api.denverwater.org/customer/v1/tapsandmeters?q=Meter.servicePointId:0865540026&fields=Meter.geometry.coordinates

0.90.9 URI Search Results:
{

  • took: 2,
  • timed_out: false,
  • _shards:
    {
    • total: 3,
    • successful: 3,
    • failed: 0
      },
  • hits:
    {
    • total: 1,
    • max_score: 11.723421,
    • hits:
      [

      {
      - _index: "customer12345",
      - _type: "TapAndMeter",
      - _id: "086554009008655400270865540026",
      - _score: 11.723421,
      - fields:
      {
      - Meter.geometry.coordinates:
      {
      - lon: -104.959796299,
      - lat: 39.7702803882
      }
      }
      }
      ]
      }

}

1.4.1 URI Search:
https://betaapi.denverwater.org/customer/v1/tapsandmeters?q=Meter.servicePointId:0865540026&fields=Meter.geometry.coordinates

1.4.1 URI Search Results:
{

  • took: 5,
  • timed_out: false,
  • _shards:
    {
    • total: 3,
    • successful: 3,
    • failed: 0
      },
  • hits:
    {
    • total: 1,
    • max_score: 11.856463,
    • hits:
      [

      {
      - _index: "customer12345",
      - _type: "TapAndMeter",
      - _id: "086554009008655400270865540026",
      - _score: 11.856463
      }
      ]
      }

}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/727ed634-7174-4146-9723-d31577bdca66%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Interesting thing to note. ... This issue is only for fields of Geo Point
Type (geo_point)
http://www.elastic.co/guide/en/elasticsearch/reference/1.4/mapping-geo-point-type.html

Tests of other fields work.

On Wednesday, April 8, 2015 at 9:56:54 AM UTC-6, Tony Nesavich wrote:

Running into an issue with URI searches not returning expected results
after upgrading from 0.90.9 to 1.4.1

The issue is that subfields are not returned when specified with
"&fields". I have confirmed that the data is there by doing the same
search without the &fields specifications and get the
Meter.geometry.coordinates. I am not seeing anything in the release notes
for 1.4.1 that indicate any change in URI search functionality.

Hoping someone has run into this already and can tell me how to specify
subfields for results sets other than the &fields method or how to get the
&fields method to work again in 1.4.1+

Thanks in advance.

0.90.9 URI Search:

https://api.denverwater.org/customer/v1/tapsandmeters?q=Meter.servicePointId:0865540026&fields=Meter.geometry.coordinates

0.90.9 URI Search Results:
{

  • took: 2,
  • timed_out: false,
  • _shards:
    {
    • total: 3,
    • successful: 3,
    • failed: 0
      },
  • hits:
    {
    • total: 1,
    • max_score: 11.723421,
    • hits:
      [

      {
      - _index: "customer12345",
      - _type: "TapAndMeter",
      - _id: "086554009008655400270865540026",
      - _score: 11.723421,
      - fields:
      {
      - Meter.geometry.coordinates:
      {
      - lon: -104.959796299,
      - lat: 39.7702803882
      }
      }
      }
      ]
      }

}

1.4.1 URI Search:

https://betaapi.denverwater.org/customer/v1/tapsandmeters?q=Meter.servicePointId:0865540026&fields=Meter.geometry.coordinates

1.4.1 URI Search Results:
{

  • took: 5,
  • timed_out: false,
  • _shards:
    {
    • total: 3,
    • successful: 3,
    • failed: 0
      },
  • hits:
    {
    • total: 1,
    • max_score: 11.856463,
    • hits:
      [

      {
      - _index: "customer12345",
      - _type: "TapAndMeter",
      - _id: "086554009008655400270865540026",
      - _score: 11.856463
      }
      ]
      }

}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c07ebb0d-087f-4337-9ea3-58a0ea0952a0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Running into an issue with URI searches not returning expected results
after upgrading from 0.90.9 to 1.4.1

The issue is that subfields are not returned when specified with "&fields".
I have confirmed that the data is there by doing the same search without
the &fields specifications and get the Meter.geometry.coordinates. I am
not seeing anything in the release notes for 1.4.1 that indicate any change
in URI search functionality.

Hoping someone has run into this already and can tell me how to specify
subfields for results sets other than the &fields method or how to get the
&fields method to work again in 1.4.1+

Thanks in advance.

0.90.9 URI Search:
https://contoso.com/customer/v1/tapsandmeters?q=Meter.servicePointId:0865540026&fields=Meter.geometry.coordinates

0.90.9 URI Search Results:
{

  • took: 2,
  • timed_out: false,
  • _shards:
    {
    • total: 3,
    • successful: 3,
    • failed: 0
      },
  • hits:
    {
    • total: 1,
    • max_score: 11.723421,
    • hits:
      [

      {
      - _index: "customer12345",
      - _type: "TapAndMeter",
      - _id: "086554009008655400270865540026",
      - _score: 11.723421,
      - fields:
      {
      - Meter.geometry.coordinates:
      {
      - lon: -104.959796299,
      - lat: 39.7702803882
      }
      }
      }
      ]
      }

}

1.4.1 URI Search:
https://newercontoso.com/customer/v1/tapsandmeters?q=Meter.servicePointId:0865540026&fields=Meter.geometry.coordinates

1.4.1 URI Search Results:
{

  • took: 5,
  • timed_out: false,
  • _shards:
    {
    • total: 3,
    • successful: 3,
    • failed: 0
      },
  • hits:
    {
    • total: 1,
    • max_score: 11.856463,
    • hits:
      [

      {
      - _index: "customer12345",
      - _type: "TapAndMeter",
      - _id: "086554009008655400270865540026",
      - _score: 11.856463
      }
      ]
      }

}

Interesting thing to note. ... This issue is only for fields of Geo Point

Type (geo_point)

http://www.elastic.co/guide/en/elasticsearch/reference/1.4/mapping-geo-point-type.html

Tests of other fields work.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/146e423b-61f2-468e-956d-724f6b0f5950%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.