Use an array as parameter

Hi all,

I'm using Datadog Metrics Plugin.

I want to use tags. I have an array of strings in my event called "datadog.tags" which I want to pass to dd_tags, which gets an array of strings:

datadog_metrics {
  api_key => "MyApiKey"
  dd_tags => "%{datadog.tags}"
  metric_name => "%{}"
  metric_type => "gauge"
  metric_value => "%{datadog.metric.value}"
  queue_size => 100
  timeframe => 60

Since it’s in parenthesis, naturally, the plugin gets a string instead of an array. Is there still no way to pass the array?

I also tried [datadog][tags] or [datadog.tags], like it’s being used in conditionals, but to no avail.

I read in a post 4 years ago that there's no way to reference an array in logstash. Is it still relevant today? Can anyone think of a workaround? The only workaround I can think of is modifying the plugin to get a comma delimited string, and do the splitting on the ruby side.

Thanks in advance,


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.