Use ruby 2 for jruby

I'm trying to write a plugin for logstash. My plugin uses a library that require ruby 2+ to run. After searching around, i found that JRuby 1.7 can support Ruby 2.x. How can i force logstash jruby to use ruby 2.0.
Thanks everyone.

Have you tried simply requiring the module?

require "module"

And seeing what happens?

Yes , i did. As reported here . I also did some research here and suspect that because ruby 1.9 does not support named arguments.
I also see that Logstash is having a plan to move to JRuby 9k which due in logstash 5.4. I will switch to that later.Now, I just need some way to force JRuby to use RUby 2.0 which is probably possible here:
However, Logstash complain when i try to do that.
Thanks you

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.