[uSeekM] Elasticsearch won't start after Tomcat restart


(s0r1n) #1

uSeekM Sesame War's (version 1.2.1) are successfully installed and the Full Text Search works as expected (https://dev.opensahara.com/projects/useekm), but Elasticsearch won't start after Tomcat restart, the issue is reproducible.

After a full reindex everything looks fine:

curl -XGET 'http://localhost:9200/_cluster/nodes/_local?&pretty=true'

{
"ok" : true,
"cluster_name" : "es.unit.test.cluster",
"nodes" : {
"1" : {
"name" : "GND",
"transport_address" : "local[1]",
"hostname" : "solinux",
"version" : "0.20.4",
"http_address" : "inet[/134.34.201.121:9200]",
"attributes" : {
"local" : "true"
}
}
}

and the following error occurs after Tomcat restart:

curl -XGET 'http://localhost:9200/_cluster/nodes/_local?&pretty=true'

curl: (7) couldn't connect to host

Here the reply from the developer: "This is an elasticsearch feature, uSeekM doesn't really play a role here." (https://dev.opensahara.com/boards/2/topics/165?r=179)

Please help, thank you in advance.


(David Pilato) #2

Sadly, you need to restart Tomcat.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 août 2013 à 11:42, s0r1n sorin.gheorghiu@uni-konstanz.de a écrit :

uSeekM Sesame War's (version 1.2.1) are successfully installed and the Full
Text Search works as expected (https://dev.opensahara.com/projects/useekm),
but Elasticsearch won't start after Tomcat restart, the issue is
reproducible.

After a full reindex everything looks fine:

curl -XGET 'http://localhost:9200/_cluster/nodes/_local?&pretty=true'

{
"ok" : true,
"cluster_name" : "es.unit.test.cluster",
"nodes" : {
"1" : {
"name" : "GND",
"transport_address" : "local[1]",
"hostname" : "solinux",
"version" : "0.20.4",
"http_address" : "inet[/134.34.201.121:9200]",
"attributes" : {
"local" : "true"
}
}
}

and the following error occurs after Tomcat restart:

curl -XGET 'http://localhost:9200/_cluster/nodes/_local?&pretty=true'

curl: (7) couldn't connect to host

Here the reply from the developer: "This is an elasticsearch feature, uSeekM
doesn't really play a role here." (
https://dev.opensahara.com/boards/2/topics/165?r=179
https://dev.opensahara.com/boards/2/topics/165?r=179 )

Please help, thank you in advance.

--
View this message in context: http://elasticsearch-users.115913.n3.nabble.com/uSeekM-Elasticsearch-won-t-start-after-Tomcat-restart-tp4039804.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(s0r1n) #3

Due to maintenance activities I may be forced to restart Tomcat or the whole server. When ES won't start, the workaround is to rebuild the uSeekM indexes which takes a couple of days. This not acceptable for a production server. Please provide your feedback. Thank you.


(David Pilato) #4

What???? When you stop your tomcat and restart it all your data are gone?

I think you have something wrong in your code or something.
I did that in production for years and never have such an issue!

Are you using NodeClient? TransportClient?
How do you connect to you elasticsearch nodes?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 20 août 2013 à 15:42, s0r1n sorin.gheorghiu@uni-konstanz.de a écrit :

Due to maintenance activities I may be forced to restart Tomcat or the whole
server. When ES won't start, the workaround is to rebuild the uSeekM indexes
which takes a couple of days. This not acceptable for a production server.
Please provide your feedback. Thank you.

--
View this message in context: http://elasticsearch-users.115913.n3.nabble.com/uSeekM-Elasticsearch-won-t-start-after-Tomcat-restart-tp4039804p4039866.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(s0r1n) #5

Yes, in the beginning all data was gone after a tomcat restart. Since I increased the hw and sw limit for the tomcat user to 32000 the data wasn't erased anymore, but ES won't start.

I can't tell if I use NodeClient or TransportClient, I haven't installed ES as standalone, but just uSeekM only. Maybe it helps to show you my config:

cluster:
name: es.unit.test.cluster
node:
name: GND
local: true
index:
number_of_shards: 1
number_of_replicas: 0
analysis:
char_filter:
my_mapping:
type: mapping
mappings: [ae=>a, oe=>o, ue=>u, ä=>a, ö=>o, ü=>u, AE=>A, OE=>O, UE=>U, Ä=>A, Ö=>O, Ü=>U]
analyzer:
default:
tokenizer: lowercase
filter: asciifolding
char_filter: my_mapping
exact:
tokenizer: keyword
filter: [lowercase, asciifolding]
char_filter: my_mapping
path:
logs: /opt/es.tst/log
data: /opt/es.tst/data
http.enabled: true
gateway.type: none
discovery.zen.ping.multicast.enabled: false

Please check it and let me know if is anything missing here. Thank you.


(s0r1n) #6

The tomcat issue with has been resolved after changing @gateway type@ from @none@ to @local@.


(system) #7