Using _index to create new indexes not working?


(Efontana) #1

We are using Redis as our buffer, the Json going into redis contains a field like this:

{"_index", "mylogs-2015.05.07"}

The elasticsearch outputter looks like this:

output
{
elasticsearch
{
cluster => 'testcluster'
flush_size => 1000
idle_flush_time => 10
manage_template => false
host => 'localhost'
port => 9300
protocol => node
}
}

From the docs I see that manage_template => false should enable the _index field to cause that index
to be used, however, I don't see an index called "mylogs-2015.05.07" instead its going to the standard
logstash-2015.05.07 one?

What am I doing wrong?

Thanks.


(system) #2