Using different mtu value in elasticsearch

Hi all,

I am setting up an ElasticSearch 1.3.4 cluster with multihomed servers (a
corporate network x.x.x.x and a server-only network at 10Gbs on z.z.z.z,
each server having two nic). I ran into some problems as I tried to use the
server-only network to do all the cluster traffic and the corporate network
to access the rest interface. I used :

  • : z.z.z.z
  • (as I use the java transport client on the coporate
  • x.x.x.x

With this settings, I could create indices, connect with the java client,
manage with HQ/head plugin, etc. The problem is when I tried to pump data
into the cluster (using bulk insert with java client, worked ok on v0.92,
updated the jar version to 1.3.4), it started to fill the shard on the
server to which the client was directly connected, but when it tried to
fill shards on other servers... it just stop, or halted. The java client
waited with no error, nothing in the servers' log... I stopped it after 15
minutes and I still no log or feedback (I use the default log settings).

To test further, I started a cluster with only one server with an index
with 3 shards and pumped some data into it. All went well. Then I joined a
second server and checked on the head plugin. I could see the state of one
shard fliped to "relocating", but it didn't changed location... I waited to
half an hour (it contained 5 000 documents with only one field with one
word in it).

After banging my head a few times, I saw that the nic on the z.z.z.z
network was setup with mtu of 9000. I changed it to a more conventional
value of 1500 and then all went well...

So is elasticsearch restricted to mtu 1500 for the transport client? Is
there a way to change it? I saw nothing in the config files. I didn't
tested it with other in-between mtu values, so maybe it's just the bad
value for the network, but other network applications ran smoothly with mtu

Thanks in advance for your time,


You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
To view this discussion on the web visit
For more options, visit

1 Like