Using HTTPS for WebHDFS Output Plugin

Hi, I am facing issues with WebHDFS.

My organization uses WebHDFS on port 50470, which is kerberized and requires HTTPS.

After following the thread in, I am still facing issues with using Kerberos Authentication with HTTPS for WebHDFS.

I am getting the following logs below:
[2018-12-10T23:08:27,237][ERROR][logstash.outputs.webhdfs ] Webhdfs check request failed. (namenode: :50470, Exception: Failed to connect to host :50470, wrong status line: "\x15\x03\x03\x00\x02\x02")

Googling the web for "\x15\x03\x03\x00\x02\x02", it appears that logstash is trying to communicate via HTTP instead of HTTPS. However, I do not see any settings that allow for communication through HTTPS (not talking about use_ssl_authentication, as I do not need to authenticate my client).

May I know if there is a way to communicate via HTTPS for WebHDFS?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.