Using kill -1 pid to force logstash to reload the configuration file does not take effect


(sockaddr_in) #1

I use the following method to make the logstash reload configuration file, but did not take effect, what is the reason?
My logstash version: 5.1.1
The method comes from https://www.elastic.co/guide/en/logstash/current/reloading-config.html#_how_automatic_config_reloading_works


(Mark Earl) #2

I have the same issue since updating to 5.1.1
I've been using this feature since it was released. But since updating to the latest version it has stopped working. I have to restart the service to get the new configuration loaded.


(sockaddr_in) #3

First´╝îthank you very much!
Meaning from 2.3 to 5.0 version can use the kill -1 command to send a SIGHUP signal to the logstash process to reload the configuration file?


(Mark Earl) #4

It worked in the version before, 5.0.2, and every other version before that. But since I updated to 5.1.1, it's stopped working.

In my logs it shows [2016-12-14T08:40:13,897][WARN ][logstash.runner ] SIGHUP received. every time I reload the process. That's normal even from before the update but it use to show a chunk of the configuration that was changed right after. Now it doesn't. It's like it doesn't see any change in the configuration or just doesn't look.


(Mark Walkom) #5

It'd be worth raising this on Github - github.com/elastic/logstash/issues :slight_smile:


(sockaddr_in) #6

Today, I tried to use 5.0.0, it can really work, the version is indeed the problem, very grateful!


(sockaddr_in) #7

Thank you:slight_smile:


(Mark Earl) #8

Just opened an issue on github #6417


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.