Using yyyyMMdd dates

I have a number of fields in the yyyyMMdd format, and I've tried to setup a
a number of date formats in my mapping to get those fields to be understood
well by the date_histogram in Kibana 3, and date type queries. Nothing
seems to work properly.

Will this work much better with with the data formatted as yyyy-MM-dd, and
to use the "type":"date" mapping ?

Thanks,
Douglas

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hey,

can you show us a gist what you did, so we can take a look, where the
problem might be?

I guess you are running into

--Alex

On Mon, Jul 22, 2013 at 9:31 PM, Douglas Moore dmoore247@gmail.com wrote:

I have a number of fields in the yyyyMMdd format, and I've tried to setup
a a number of date formats in my mapping to get those fields to be
understood well by the date_histogram in Kibana 3, and date type queries.
Nothing seems to work properly.

Will this work much better with with the data formatted as yyyy-MM-dd, and
to use the "type":"date" mapping ?

Thanks,
Douglas

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Alex,
Quite possibly the same error as during my query tests on the field it
responded as an integer.

When the data is formatted as yyyy-MM-dd the date_histogram & Kibana 3 did
work better. Date filtering such as dob < 1900 worked well too.
I had to change the format from "type":"date", "format:"basicDate" to
simple "type":"date"

Re: Gist: I don't have a good isolated test.

Is there a work around to issue 2937 ? I'm on 0.90.0 release.

Thanks,
Douglas

On Tuesday, July 23, 2013 2:23:44 AM UTC-4, Alexander Reelsen wrote:

Hey,

can you show us a gist what you did, so we can take a look, where the
problem might be?

I guess you are running into
https://github.com/elasticsearch/elasticsearch/issues/2937

--Alex

On Mon, Jul 22, 2013 at 9:31 PM, Douglas Moore <dmoo...@gmail.com<javascript:>

wrote:

I have a number of fields in the yyyyMMdd format, and I've tried to setup
a a number of date formats in my mapping to get those fields to be
understood well by the date_histogram in Kibana 3, and date type queries.
Nothing seems to work properly.

Will this work much better with with the data formatted as yyyy-MM-dd,
and to use the "type":"date" mapping ?

Thanks,
Douglas

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.