Version 5.5.1 - timeout not working


(Eran H) #1

I would like long queries to kill themselves after ~ 30 seconds, in case of unexpected scenarios of growing load on the server.
It already happened that my whole cluster was under heavy load with a growing pile of search tasks (by checking GET _tasks).

I am testing the timeout parameter like this

POST index_name/_search?timeout=1nanos
{
  "size": 10000
}

but I get in the result:

{
  "took": 38,
  "timed_out": false,
}

I also tried with heavier aggregation that took 10 seconds and it doesn't time out.

  1. What does the timeout parameter do?
  2. Is there any way to accomplish this?

(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.