"View in Sense" not loading sample json

Hello,

I'm going through the definitive guide for elastic search learning. I've
got Marvel up and running on my local windows. I'm able to run commands
against elastic search, etc. In the definitive guide there are "View in
Sense" links.

E.g.
http://www.elastic.co/guide/en/elasticsearch/guide/master/sense_widget.html?snippets/010_Intro/10_Info.json,
which in Sense redirects to:
http://localhost:9200/_plugin/marvel/sense/index.html?load_from=http://www.elastic.co/guide/en/elasticsearch/guide/master/snippets/010_Intro/10_Info.json.

Which should load:

Check that Elasticsearch is running

GET /

However, it always loads the default json and never anything else:

GET _search
{
"query": { "match_all": {} }
}

Not a big deal, I can copy/paste the example json, but anybody experienced this?

I've enabled cors settings in elasticsearch.yml.

Thanks,
Nate

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ba409e43-435c-4c55-ad82-5914242924fa%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I've created a Youtube video demo'ing the issue I'm seeing. Kind of
annoying I can't figure this out. I'm sure the answer is stupid simple, but
I'm not finding and I have searched, which is ironic.

On Thursday, March 19, 2015 at 9:28:21 AM UTC-7, Zelfapp wrote:

Hello,

I'm going through the definitive guide for elastic search learning. I've
got Marvel up and running on my local windows. I'm able to run commands
against elastic search, etc. In the definitive guide there are "View in
Sense" links.

E.g.
http://www.elastic.co/guide/en/elasticsearch/guide/master/sense_widget.html?snippets/010_Intro/10_Info.json,
which in Sense redirects to:
http://localhost:9200/_plugin/marvel/sense/index.html?load_from=http://www.elastic.co/guide/en/elasticsearch/guide/master/snippets/010_Intro/10_Info.json
.

Which should load:

Check that Elasticsearch is running

GET /

However, it always loads the default json and never anything else:

GET _search
{
"query": { "match_all": {} }
}

Not a big deal, I can copy/paste the example json, but anybody experienced this?

I've enabled cors settings in elasticsearch.yml.

Thanks,
Nate

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4c793a28-9b90-4dce-acbb-96a93f12ea09%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You need the server in there, I don't know why it doesn't add that
automatically but that's why you are getting the CORS error, it is a
misleading response.

It'd be worth raising this as an issue on Github against the Elasticsearch
project :slight_smile:

On 19 March 2015 at 09:43, Zelfapp nate@usamm.com wrote:

I've created a Youtube video demo'ing the issue I'm seeing. Kind of
annoying I can't figure this out. I'm sure the answer is stupid simple, but
I'm not finding and I have searched, which is ironic.

https://youtu.be/4Ksb0t_9Ym0

On Thursday, March 19, 2015 at 9:28:21 AM UTC-7, Zelfapp wrote:

Hello,

I'm going through the definitive guide for elastic search learning. I've
got Marvel up and running on my local windows. I'm able to run commands
against elastic search, etc. In the definitive guide there are "View in
Sense" links.

E.g. http://www.elastic.co/guide/en/elasticsearch/guide/master/
sense_widget.html?snippets/010_Intro/10_Info.json, which in Sense
redirects to: http://localhost:9200/plugin/marvel/sense/index.html?load
from=http://www.elastic.co/guide/en/elasticsearch/guide/
master/snippets/010_Intro/10_Info.json.

Which should load:

Check that Elasticsearch is running

GET /

However, it always loads the default json and never anything else:

GET _search
{
"query": { "match_all": {} }
}

Not a big deal, I can copy/paste the example json, but anybody experienced this?

I've enabled cors settings in elasticsearch.yml.

Thanks,
Nate

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4c793a28-9b90-4dce-acbb-96a93f12ea09%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/4c793a28-9b90-4dce-acbb-96a93f12ea09%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-JhCn4zZOQoCDV%3DW_%3DW10n6sbR9-w_UQLJWV0CGfm9hA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Hello Mark,

You can see I already raised it on github and received a response. This
issue will be temporary and is related to Elastic changing their domain and
not updating the CORS header in the definitive guide.

Thanks for the reply.

On Thursday, March 19, 2015 at 11:17:42 AM UTC-7, Mark Walkom wrote:

You need the server in there, I don't know why it doesn't add that
automatically but that's why you are getting the CORS error, it is a
misleading response.

It'd be worth raising this as an issue on Github against the Elasticsearch
project :slight_smile:

On 19 March 2015 at 09:43, Zelfapp <na...@usamm.com <javascript:>> wrote:

I've created a Youtube video demo'ing the issue I'm seeing. Kind of
annoying I can't figure this out. I'm sure the answer is stupid simple, but
I'm not finding and I have searched, which is ironic.

https://youtu.be/4Ksb0t_9Ym0

On Thursday, March 19, 2015 at 9:28:21 AM UTC-7, Zelfapp wrote:

Hello,

I'm going through the definitive guide for elastic search learning. I've
got Marvel up and running on my local windows. I'm able to run commands
against elastic search, etc. In the definitive guide there are "View in
Sense" links.

E.g. http://www.elastic.co/guide/en/elasticsearch/guide/master/
sense_widget.html?snippets/010_Intro/10_Info.json, which in Sense
redirects to: http://localhost:9200/_plugin/
marvel/sense/index.html?load_from=http://www.elastic.co/
guide/en/elasticsearch/guide/master/snippets/010_Intro/10_Info.json.

Which should load:

Check that Elasticsearch is running

GET /

However, it always loads the default json and never anything else:

GET _search
{
"query": { "match_all": {} }
}

Not a big deal, I can copy/paste the example json, but anybody experienced this?

I've enabled cors settings in elasticsearch.yml.

Thanks,
Nate

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4c793a28-9b90-4dce-acbb-96a93f12ea09%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/4c793a28-9b90-4dce-acbb-96a93f12ea09%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/644efee4-98c8-4acf-85d9-a66c94da8da8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.