WARN Monitor.jvm


(Sunil Chaudhari) #1

Hello,
I am facing below issue in elasticsearch indexing. It seems indexing has got slower. There is difference of around 5-7 hrs in actual log time and the time it gets stored in DB.

ES logs says below in log file.

[2015-08-19 11:21:53,846][WARN ][monitor.jvm ] [presit-data-Node-2] [gc][old][1407][304] duration [13.2s], collections [1]/[13.5s], total [13.2s]/[1h], memory [998.3mb]->[995.6mb]/[1007.3mb], all_pools {[young] [133.1mb]->[133.1mb]/[133.1mb]}{[survivor] [7.6mb]->[4.9mb]/[16.6mb]}{[old] [857.6mb]->[857.6mb]/[857.6mb]}

I cant understand what its mean?
I tried following but it didn't solve the issue.

  1. heap space increased to 3 GB. Still it shows 1 GB heap size on node diagnostic through elastic-HQ?
  2. sudo swapoff -a

Please guide me on this.

thanks
Sunil Chaudhari.


ElasticSearch 2.3.4 grinding to a halt
(Sunil Chaudhari) #2

Hi,
Can anybody reply on this?
Please tell me what does it mean and what might be the reason?

thanks
Sunil


#3

This is old generation GC message. It took 13.2 seconds to clean your old gen. It also seems like your old generation is full evern after collection -- [old] [857.6mb]->[857.6mb]/[857.6mb].

How did you increase the heap? Did you do it like ES_HEAP_SIZE=1g? or something else?


(Sunil Chaudhari) #4

Hi Abhijit,
Thanks for the reply.
I have increased heap size by editing file /etc/sysconfig/elasticsearch. It did not help but at least I could see heap size change from ES-HQ diagnostic page.
setting parameter ES_HEAP_SIZE=1g had no effect on heap size.
I just made some changes in master/data node and cluster is working, but I fear it will arise again.

br,
Sunil


(system) #5