Warning Could not find logstash.yml

WARNING: Could not find logstash.yml which is typically located in $LS_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults

I see that there are others that have the same problem, and I have tried using the --path.settings, and also tried to change the startup.options, but I still get the warning.

I want to run multiple logstash.conf files, since the one I already have is quite long, and it wold be easier to keep track of things if I had multiple config files.

Can someone help me?

Are you running logstash as a service? If so, exactly how is it started?

/usr/share/logstash/bin/logstash -f /etc/logstash/conf.d/logstash.conf

I'm using this command

And you are saying that when you add --path.settings pointing to a directory that contains a file called logstash.yml it does not find it? Do you have the LS_SETTINGS_DIR environment variable set?

Yes to both of the questions, and still it does not find it.

[FATAL] 2019-07-15 08:30:29.876 [main] runner - An unexpected error occurred! 
{:error=>#<TypeError: no implicit conversion of nil into String>, :backtrace=> 
["org/jruby/RubyFileTest.java:96:in `directory?'", "org/jruby/RubyFileTest.java:88:in `directory?'", 
"/usr/share/logstash/logstash-core/lib/logstash/settings.rb:468:in `block in value'", 
"org/jruby/RubyKernel.java:1885:in `tap'", "/usr/share/logstash/logstash-
core/lib/logstash/settings.rb:467:in `value'", "/usr/share/logstash/logstash-
core/lib/logstash/settings.rb:64:in `get_value'", "/usr/share/logstash/logstash-
core/lib/logstash/environment.rb:92:in `block in LogStash'", "/usr/share/logstash/logstash-
core/lib/logstash/settings.rb:125:in `block in post_process'", "org/jruby/RubyArray.java:1792:in 
`each'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:124:in `post_process'", 
"/usr/share/logstash/logstash-core/lib/logstash/util/settings_helper.rb:26:in `post_process'", 
"/usr/share/logstash/logstash-core/lib/logstash/runner.rb:241:in `execute'", 
"/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/clamp-0.6.5/lib/clamp/command.rb:67:in 
`run'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:237:in `run'", 
"/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/clamp-
0.6.5/lib/clamp/command.rb:132:in `run'", 
"/usr/share/logstash/lib/bootstrap/environment.rb:73:in `<main>'"]}

[ERROR] 2019-07-15 08:30:29.898 [main] Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

Now I get this error when I use the --path.settings /etc/logstash