Was anxious to try Kibana 7.5.2 docker. Doesn't work

I ran elastic 7.5.2 docker and kibana 7.5.2 docker. I go to the kibana url and it says

"statusCode": 400,
"error": "Bad Request",
"message": "Invalid cookie header"

A shame. Any idea why it's broken?

$ docker run --link 64bcd8d6469c:elasticsearch -p 5601:5601 docker.elastic.co/kibana/kibana:7.5.2

Try checking your kibana.yml file.
May be try this : Edit your kibana.yml

Remove comment from bellow lines ,if server.host is bound to localhost - no problems

elasticsearch.url: "http://localhost:9200"

restart kibana and try to access it. Also, does this happen in an incognito window? Maybe some browser plugin causing issues? Kibana doesn't use cookies.

Hope it helps


Do you have a specific use case for using the --link parameter?

In case you don't want to expose your ES container on all interfaces at 9200, creating a docker network and then using it to run the two containers would be a better option.

$ docker network create ES --driver=overlay2 --attachable
$ docker run --network=ES docker.elastic.co/elasticsearch/elasticsearch:7.5.2
$ docker run --network=ES -p 5601:5601 docker.elastic.co/kibana/kibana:7.5.2

In case you don't mind exposing ES on all interfaces (only for testing), you can simply skip the network creation and flags while running the two containers. I made no changes to my yml files while running these commands for testing, and it worked. Did you edit your yml?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.