Watcher EmailAction throwing Exception

Hello Team,
Version Used: 7.4
I am facing the following issue while working with Elasticsearch watcher Email Action .

"condition": {
      "type": "compare",
      "status": "success",
      "met": true,
      "compare": {
        "resolved_values": {
          "ctx.payload.hits.total": 38
        }
      }
    },
    "actions": [
      {
        "id": "log",
        "type": "logging",
        "status": "success",
        "logging": {
          "logged_text": "WARNING ON eaas index executed at 2020-03-16T06:33:15.652Z"
        }
      },
      {
        "id": "send_email",
        "type": "email",
        "status": "failure",
        "error": {
          "root_cause": [
            {
              **"type": "settings_exception",**
**              "reason": "missing required email account setting for account [gmail_account]. 'smtp.host' must be configured**"
            }
          ],
          "type": "settings_exception",
          "reason": "missing required email account setting for account [gmail_account]. 'smtp.host' must be configured"
        }
      }
    ]
  },
  "messages": []

I have used below configuration in elasticsearch.yml file to do this
xpack.notification.email.account:
    outlook_account:
        profile: outlook
        smtp:
            auth: true
            starttls.enable: true
            host: smtp-mail.outlook.com
            port: 587
            user: email.address

I am facing issue due to 'gmail' eventhough I have used outlook in configuration file.One thing that i have started to try this with gmail account and later changed it into outlook. I have restarted the services after this. Do I need to update anything else here to solve this. It would be great to help me out on this. Please let me know if I need to share more info on this.

you have configured an email account named outlook_account (which can be an arbitrary name), you refer in your watch to an account named gmail_account

Also make sure you update your confguration on all nodes and restart, if you are using the configuration file.